]> git.pld-linux.org Git - packages/perl-XML-Mini.git/blob - perl-XML-Mini.spec
- oops... cosmetic fixes.
[packages/perl-XML-Mini.git] / perl-XML-Mini.spec
1 #
2 # Conditional build:
3 # _without_tests - do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    XML
7 %define pnam    Mini
8 Summary:        XML::Mini - Perl implementation of the XML::Mini XML create/parse interface.
9 #Summary(pl):   
10 Name:           perl-XML-Mini
11 Version:        1.2.7
12 Release:        1
13 License:        GPL v2+
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 BuildRequires:  perl-devel >= 5.6
17 BuildRequires:  rpm-perlprov >= 4.1-13
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 XML::Mini is a set of Perl classes that allow you to access XML data
23 and create valid XML output with a tree-based hierarchy of elements.
24 The MiniXML API has both Perl and PHP implementations.
25
26 # %description -l pl
27 # TODO
28
29 %prep
30 %setup -q -n %{pdir}-%{pnam}-%{version}
31
32 %build
33 %{__perl} Makefile.PL \
34         INSTALLDIRS=vendor
35 %{__make}
36
37 %{!?_without_tests:%{__make} test}
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41
42 %{__make} install \
43         DESTDIR=$RPM_BUILD_ROOT
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %files
49 %defattr(644,root,root,755)
50 %{perl_vendorlib}/%{pdir}/*.pm
51 %{perl_vendorlib}/%{pdir}/%{pnam}
52 %{_mandir}/man3/*
This page took 0.049265 seconds and 4 git commands to generate.