]> git.pld-linux.org Git - packages/perl-XML-LibXSLT.git/blob - perl-XML-LibXSLT.spec
- BR: pkgconfig
[packages/perl-XML-LibXSLT.git] / perl-XML-LibXSLT.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    XML
7 %define         pnam    LibXSLT
8 Summary:        XML::LibXSLT - interface to the GNOME libxslt library
9 Summary(pl.UTF-8):      XML::LibXSLT - interfejs do biblioteki libxslt z GNOME
10 Name:           perl-XML-LibXSLT
11 Version:        1.70
12 Release:        3
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/XML/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  c63a7913999de076e5c911810f69b392
18 URL:            http://search.cpan.org/dist/XML-LibXSLT/
19 BuildRequires:  libxslt-devel >= 1.0.6
20 BuildRequires:  perl-XML-LibXML >= 1.60
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  pkgconfig
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 Requires:       libxslt >= 1.0.6
25 Requires:       perl-XML-LibXML >= 1.57
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 This module is an interface to the GNOME project's libxslt. This is an
30 extremely good XSLT engine, highly compliant and also very fast. I
31 have tests showing this to be more than twice as fast as Sablotron.
32
33 %description -l pl.UTF-8
34 Ten moduł jest interfejsem do libxslt z projektu GNOME. Jest to bardzo
35 dobry silnik XSLT, o dużej zgodności ze standardem, a także bardzo
36 szybki. Według testów jest ponad dwa razy szybszy od Sablotrona.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make} \
45         CC="%{__cc}" \
46         OPTIMIZE="%{rpmcflags}"
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
57 install example/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc Changes README
65 %{perl_vendorarch}/XML/LibXSLT.pm
66 %{perl_vendorarch}/XML/benchmark.pl
67 %dir %{perl_vendorarch}/auto/XML/LibXSLT
68 %{perl_vendorarch}/auto/XML/LibXSLT/LibXSLT.bs
69 %attr(755,root,root) %{perl_vendorarch}/auto/XML/LibXSLT/LibXSLT.so
70 %{_mandir}/man3/*
71 %{_examplesdir}/%{name}-%{version}
This page took 0.060378 seconds and 4 git commands to generate.