]> git.pld-linux.org Git - packages/perl-XML-LibXSLT.git/blob - perl-XML-LibXSLT.spec
- release 2
[packages/perl-XML-LibXSLT.git] / perl-XML-LibXSLT.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    XML
7 %define         pnam    LibXSLT
8 Summary:        XML::LibXSLT - interface to the GNOME libxslt library
9 Summary(pl.UTF-8):      XML::LibXSLT - interfejs do biblioteki libxslt z GNOME
10 Name:           perl-XML-LibXSLT
11 Version:        1.70
12 Release:        2
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/XML/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  c63a7913999de076e5c911810f69b392
18 URL:            http://search.cpan.org/dist/XML-LibXSLT/
19 BuildRequires:  libxslt-devel >= 1.0.6
20 BuildRequires:  perl-XML-LibXML >= 1.60
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 Requires:       libxslt >= 1.0.6
24 Requires:       perl-XML-LibXML >= 1.57
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This module is an interface to the GNOME project's libxslt. This is an
29 extremely good XSLT engine, highly compliant and also very fast. I
30 have tests showing this to be more than twice as fast as Sablotron.
31
32 %description -l pl.UTF-8
33 Ten moduł jest interfejsem do libxslt z projektu GNOME. Jest to bardzo
34 dobry silnik XSLT, o dużej zgodności ze standardem, a także bardzo
35 szybki. Według testów jest ponad dwa razy szybszy od Sablotrona.
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39
40 %build
41 %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43 %{__make} \
44         CC="%{__cc}" \
45         OPTIMIZE="%{rpmcflags}"
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
56 install example/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc Changes README
64 %{perl_vendorarch}/XML/LibXSLT.pm
65 %{perl_vendorarch}/XML/benchmark.pl
66 %dir %{perl_vendorarch}/auto/XML/LibXSLT
67 %{perl_vendorarch}/auto/XML/LibXSLT/LibXSLT.bs
68 %attr(755,root,root) %{perl_vendorarch}/auto/XML/LibXSLT/LibXSLT.so
69 %{_mandir}/man3/*
70 %{_examplesdir}/%{name}-%{version}
This page took 0.093433 seconds and 4 git commands to generate.