]> git.pld-linux.org Git - packages/perl-XML-LibXML.git/blob - perl-XML-LibXML.spec
- release 4: BR: gdome2-devel
[packages/perl-XML-LibXML.git] / perl-XML-LibXML.spec
1 #
2 # Conditional build:
3 # _with_tests - perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    XML
7 %define         pnam    LibXML
8 Summary:        XML::LibXML - Interface to the gnome libxml2 library
9 Summary(pl):    XML::LibXML - Interfejs do biblioteki libxml2 z gnome
10 Name:           perl-%{pdir}-%{pnam}
11 %define         _ver    1.54_3
12 Version:        %(echo %{_ver} | sed 's:_:\.:')
13 Release:        4
14 # same as perl
15 License:        GPL/Artistic
16 Group:          Development/Languages/Perl
17 #Source0:       http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
18 Source0:        http://www.cpan.org/authors/id/P/PH/PHISH/%{pdir}-%{pnam}-%{_ver}.tar.gz
19 # Source0-md5:  888d33be26b89ead449b2995a1e2adac
20 Patch0:         %{name}-Makefile.patch
21 BuildRequires:  gdome2-devel >= 0.7.3
22 BuildRequires:  libxml2-devel >= 2.4.8
23 BuildRequires:  perl-XML-LibXML-Common
24 BuildRequires:  perl-XML-NamespaceSupport >= 1.07
25 BuildRequires:  perl-XML-SAX >= 0.11
26 BuildRequires:  perl-devel >= 5.6.1
27 BuildRequires:  rpm-perlprov >= 4.1-13
28 Requires:       libxml2 >= 2.4.8
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 This module implements much of the DOM Level 2 API as an interface to
33 the Gnome libxml2 library. This makes it a fast and highly capable
34 validating XML parser library, as well as a high performance DOM.
35
36 %description -l pl
37 Ten modu³ to implementacja wiêkszo¶ci API DOM Level 2 jako interfejsu
38 do biblioteki Gnome libxml2. Daje to szybki i o du¿ych mo¿liwo¶ciach
39 parser sprawdzaj±cy poprawno¶æ XML, a tak¿e wysoko wydajny DOM.
40
41 %package SAX
42 Summary:        XML::LibXML::SAX perl module
43 Summary(pl):    Modu³ perla XML::LibXML::SAX
44 Group:          Development/Languages/Perl
45 Requires:       %{name} = %{version}
46
47 %description SAX
48 This class allows you to generate SAX2 events using LibXML. Note that
49 this is not a stream based parser, instead it parses documents into a
50 DOM and traverses the DOM tree. The reason being that libxml2's stream
51 based parsing is extremely primitive, and would require an extreme
52 amount of work to allow SAX2 parsing in a stream manner.
53
54 %description SAX -l pl
55 Ta klasa pozwala generowaæ zdarzenia SAX2 przy u¿yciu LibXML2. To nie
56 jest parser bazuj±cy na strumieniach - przetwarza dokumenty na DOM i
57 nastêpnie wêdruje po drzewie DOM. Wynika to z faktu, ¿e w libxml2
58 parsowanie oparte na strumieniach jest bardzo prymitywne i wymaga³oby
59 wiele pracy, aby umo¿liwiæ strumieniowe parsowanie SAX2.
60
61 %prep
62 %setup -q -n %{pdir}-%{pnam}-%{_ver}
63 %patch0 -p1
64
65 %build
66 %{__perl} Makefile.PL \
67         INSTALLDIRS=vendor 
68 %{__make} OPTIMIZE="%{rpmcflags}"
69
70 # dtd test fails for unknown reason
71 %{?_with_tests:%{__make} test}
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
76
77 %{__make} install DESTDIR=$RPM_BUILD_ROOT
78
79 install example/{*.pl,*.xml,*.dtd,*.xhtml} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
80
81 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/complex
82 install example/complex/{*.xml,*.dtd} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/complex
83
84 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/complex/dtd
85 install example/complex/dtd/*.dtd $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/complex/dtd
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %post SAX
91 umask 022
92 %{__perl} -MXML::SAX -e "XML::SAX->add_parser(q(XML::LibXML::SAX::Parser))->save_parsers()"
93
94 %preun SAX
95 umask 022
96 %{__perl} -MXML::SAX -e "XML::SAX->remove_parser(q(XML::LibXML::SAX::Parser))->save_parsers()"
97
98 %files
99 %defattr(644,root,root,755)
100 %doc Changes README
101 %{perl_vendorarch}/XML/LibXML.pm
102 %{perl_vendorarch}/XML/LibXML/[^S]*.pm
103 %{perl_vendorarch}/auto/XML/LibXML/LibXML.bs
104 %attr(755,root,root) %{perl_vendorarch}/auto/XML/LibXML/LibXML.so
105 %{_mandir}/man3/XML::LibXML.3pm*
106 %{_mandir}/man3/XML::LibXML::[^S]*
107 %dir %{_examplesdir}/%{name}-%{version}
108 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/x*.pl
109 %{_examplesdir}/%{name}-%{version}/[^x]*
110
111 %files SAX
112 %defattr(644,root,root,755)
113 %dir %{perl_vendorarch}/XML/LibXML/SAX
114 %{perl_vendorarch}/XML/LibXML/SAX.pm
115 %{perl_vendorarch}/XML/LibXML/SAX/*.pm
116 %{_mandir}/man3/XML::LibXML::SAX.3pm*
117 %{_mandir}/man3/XML::LibXML::SAX::*
This page took 0.035497 seconds and 4 git commands to generate.