]> git.pld-linux.org Git - packages/perl-XML-LibXML.git/blob - perl-XML-LibXML.spec
- corrected man list
[packages/perl-XML-LibXML.git] / perl-XML-LibXML.spec
1 %include        /usr/lib/rpm/macros.perl
2
3 %define pdir    XML
4 %define pnam    LibXML
5
6 Summary:        XML::LibXML perl module
7 Summary(pl):    Modu³ perla XML::LibXML
8 Name:           perl-%{pdir}-%{pnam}
9 Version:        1.51
10 Release:        1
11 License:        GPL
12 Group:          Development/Languages/Perl
13 Source0:        ftp://ftp.cpan.org/pub/CPAN/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
14 Patch0:         %{name}-Makefile.patch
15 BuildRequires:  rpm-perlprov >= 4.0.2-56
16 BuildRequires:  perl-devel >= 5.6.1
17 BuildRequires:  perl-XML-SAX
18 BuildRequires:  libxml2-devel >= 2.4.8
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20 Requires:       libxml2 >= 2.4.8
21
22 %description
23 This module implements much of the DOM Level 2 API as an interface to
24 the Gnome libxml2 library. This makes it a fast and highly capable
25 validating XML parser library, as well as a high performance DOM.
26
27 %description -l pl
28 Ten modu³ to implementacja wiêkszo¶ci API DOM Level 2 jako interfejsu
29 do biblioteki Gnome libxml2. Daje to szybki i o du¿ych mo¿liwo¶ciach
30 parser sprawdzaj±cy poprawno¶æ XML, a tak¿e wysoko wydajny DOM.
31
32 %package SAX
33 Summary:        XML::LibXML-SAX perl module
34 Summary(pl):    Modu³ perla XML::LibXML-SAX
35 Group:          Development/Languages/Perl
36
37 %description SAX
38 This class allows you to generate SAX2 events using LibXML. Note that
39 this is not a stream based parser, instead it parses documents into a
40 DOM and traverses the DOM tree. The reason being that libxml2's stream
41 based parsing is extremely primitive, and would require an extreme
42 amount of work to allow SAX2 parsing in a stream manner.
43
44 %description SAX -l pl
45 Ta klasa pozwala generowaæ zdarzenia SAX2 przy u¿yciu LibXML2. To nie
46 jest parser bazuj±cy na strumieniach - przetwarza dokumenty na DOM i
47 nastêpnie wêdruje po drzewie DOM. Wynika to z faktu, ¿e w libxml2
48 parsowanie oparte na strumieniach jest bardzo prymitywne i wymaga³oby
49 wiele pracy, aby umo¿liwiæ strumieniowe parsowanie SAX2.
50
51 %prep
52 %setup -q -n %{pdir}-%{pnam}-%{version}
53 %patch0 -p1
54
55 %build
56 perl Makefile.PL
57 %{__make} OPTIMIZE="%{rpmcflags}"
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
62
63 %{__make} install DESTDIR=$RPM_BUILD_ROOT
64
65 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
66 install example/{*.pl,*.xml,*.dtd,*.xhtml} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
67
68 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/complex
69 install example/complex/{*.xml,*.dtd} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/complex
70
71 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/complex/dtd
72 install example/complex/dtd/*.dtd $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/complex/dtd
73
74 gzip -9nf Changes README PHISHS.CHANGES
75
76 %post SAX
77 perl -MXML::SAX -e "XML::SAX->add_parser(q(XML::LibXML::SAX::Parser))->save_parsers()"
78
79 %preun SAX
80 perl -MXML::SAX -e "XML::SAX->remove_parser(q(XML::LibXML::SAX::Parser))->save_parsers()"
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %files
86 %defattr(644,root,root,755)
87 %doc *.gz
88 %{perl_sitearch}/XML/LibXML.pm
89 %dir %{perl_sitearch}/XML/LibXML
90 %{perl_sitearch}/XML/LibXML/*.pm
91 %{perl_sitearch}/XML/LibXML/*.pod
92 %dir %{perl_sitearch}/auto/XML/LibXML
93 %{perl_sitearch}/auto/XML/LibXML/LibXML.bs
94 %attr(755,root,root) %{perl_sitearch}/auto/XML/LibXML/LibXML.so
95 %{_mandir}/man3/XML::LibXML.3pm.gz
96 %{_mandir}/man3/XML::LibXML::[^S][^A][^X]*
97 %{_examplesdir}/%{name}-%{version}
98
99 %files SAX
100 %defattr(644,root,root,755)
101 %dir %{perl_sitearch}/XML/LibXML/SAX
102 %{perl_sitearch}/XML/LibXML/SAX/*.pm
103 %{_mandir}/man3/XML::LibXML::SAX.3pm.gz
104 %{_mandir}/man3/XML::LibXML::SAX::*
This page took 0.083823 seconds and 3 git commands to generate.