]> git.pld-linux.org Git - packages/perl-XML-LibXML.git/blob - perl-XML-LibXML.spec
- version 1.65
[packages/perl-XML-LibXML.git] / perl-XML-LibXML.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    XML
7 %define         pnam    LibXML
8 Summary:        XML::LibXML - interface to the GNOME libxml2 library
9 Summary(pl.UTF-8):      XML::LibXML - interfejs do biblioteki libxml2 z GNOME
10 Name:           perl-XML-LibXML
11 Version:        1.65
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/XML/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  7871c21078f706690cda9ca68d4ddac6
18 URL:            http://search.cpan.org/dist/XML-LibXML/
19 BuildRequires:  gdome2-devel >= 0.7.3
20 BuildRequires:  libxml2-devel >= 2.5.10
21 BuildRequires:  perl-XML-LibXML-Common
22 BuildRequires:  perl-XML-NamespaceSupport >= 1.07
23 BuildRequires:  perl-XML-SAX >= 0.11
24 BuildRequires:  perl-devel >= 1:5.8.0
25 BuildRequires:  pkgconfig
26 BuildRequires:  rpm-perlprov >= 4.1-13
27 Requires:       libxml2 >= 2.5.10
28 Provides:       perl-XML-LibXML-XPathContext = %{version}
29 Obsoletes:      perl-XML-LibXML-XPathContext <= 0:0.07
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 This module implements much of the DOM Level 2 API as an interface to
34 the GNOME libxml2 library. This makes it a fast and highly capable
35 validating XML parser library, as well as a high performance DOM.
36
37 %description -l pl.UTF-8
38 Ten moduł to implementacja większości API DOM Level 2 jako interfejsu
39 do biblioteki GNOME libxml2. Daje to szybki i o dużych możliwościach
40 parser sprawdzający poprawność XML-a, a także wysoko wydajny DOM.
41
42 %package SAX
43 Summary:        XML::LibXML::SAX Perl module - XML::LibXML direct SAX parser
44 Summary(pl.UTF-8):      Moduł Perla XML::LibXML::SAX - bezpośredni parser SAX z XML::LibXML
45 Group:          Development/Languages/Perl
46 Requires:       %{name} = %{version}-%{release}
47
48 %description SAX
49 This class allows you to generate SAX2 events using LibXML. Note that
50 this is not a stream based parser, instead it parses documents into a
51 DOM and traverses the DOM tree. The reason being that libxml2's stream
52 based parsing is extremely primitive, and would require an extreme
53 amount of work to allow SAX2 parsing in a stream manner.
54
55 %description SAX -l pl.UTF-8
56 Ta klasa pozwala generować zdarzenia SAX2 przy użyciu LibXML2. To nie
57 jest parser bazujący na strumieniach - przetwarza dokumenty na DOM i
58 następnie wędruje po drzewie DOM. Wynika to z faktu, że w libxml2
59 parsowanie oparte na strumieniach jest bardzo prymitywne i wymagałoby
60 wiele pracy, aby umożliwić strumieniowe parsowanie SAX2.
61
62 %prep
63 %setup -q -n %{pdir}-%{pnam}-%{version}
64
65 %build
66 SKIP_SAX_INSTALL=true;
67 export SKIP_SAX_INSTALL
68
69 %{__perl} Makefile.PL \
70         INSTALLDIRS=vendor
71 %{__make} \
72         OPTIMIZE="%{rpmcflags}"
73
74 %{?with_tests:%{__make} test}
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
79
80 %{__make} install \
81         DESTDIR=$RPM_BUILD_ROOT
82 install example/{*.pl,*.xml,*.dtd,*.xhtml} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
83
84 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/complex
85 install example/complex/{*.xml,*.dtd} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/complex
86
87 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/complex/dtd
88 install example/complex/dtd/*.dtd $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/complex/dtd
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %post SAX
94 umask 022
95 %{__perl} -MXML::SAX -e "XML::SAX->add_parser(q(XML::LibXML::SAX::Parser))->save_parsers()"
96
97 %preun SAX
98 if [ "$1" = "0" ]; then
99         umask 022
100         %{__perl} -MXML::SAX -e "XML::SAX->remove_parser(q(XML::LibXML::SAX::Parser))->save_parsers()"
101 fi
102
103 %files
104 %defattr(644,root,root,755)
105 %doc Changes README
106 %{perl_vendorarch}/XML/LibXML.pm
107 %{perl_vendorarch}/XML/LibXML/[!S]*.pm
108 %{perl_vendorarch}/auto/XML/LibXML/LibXML.bs
109 %attr(755,root,root) %{perl_vendorarch}/auto/XML/LibXML/LibXML.so
110 %{_mandir}/man3/XML::LibXML.3pm*
111 %{_mandir}/man3/XML::LibXML::[!S]*
112 %{_mandir}/man3/XML::LibXML::S[!A]*
113 %dir %{_examplesdir}/%{name}-%{version}
114 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/x*.pl
115 %{_examplesdir}/%{name}-%{version}/[!x]*
116
117 %files SAX
118 %defattr(644,root,root,755)
119 %dir %{perl_vendorarch}/XML/LibXML/SAX
120 %{perl_vendorarch}/XML/LibXML/SAX.pm
121 %{perl_vendorarch}/XML/LibXML/SAX/*.pm
122 %{_mandir}/man3/XML::LibXML::SAX.3pm*
123 %{_mandir}/man3/XML::LibXML::SAX::*
This page took 0.04476 seconds and 3 git commands to generate.