]> git.pld-linux.org Git - packages/perl-XML-LibXML.git/blob - perl-XML-LibXML.spec
603252086aded64b72e497aa786189b36cf3c9d9
[packages/perl-XML-LibXML.git] / perl-XML-LibXML.spec
1 #
2 # Conditional build:
3 # _with_tests - perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    XML
7 %define         pnam    LibXML
8 Summary:        XML::LibXML Perl module
9 Summary(cs):    Modul XML::LibXML pro Perl
10 Summary(da):    Perlmodul XML::LibXML
11 Summary(de):    XML::LibXML Perl Modul
12 Summary(es):    Módulo de Perl XML::LibXML
13 Summary(fr):    Module Perl XML::LibXML
14 Summary(it):    Modulo di Perl XML::LibXML
15 Summary(ja):    XML::LibXML Perl ¥â¥¸¥å¡¼¥ë
16 Summary(ko):    XML::LibXML ÆÞ ¸ðÁÙ
17 Summary(no):    Perlmodul XML::LibXML
18 Summary(pl):    Modu³ Perla XML::LibXML
19 Summary(pt):    Módulo de Perl XML::LibXML
20 Summary(pt_BR): Módulo Perl XML::LibXML
21 Summary(ru):    íÏÄÕÌØ ÄÌÑ Perl XML::LibXML
22 Summary(sv):    XML::LibXML Perlmodul
23 Summary(uk):    íÏÄÕÌØ ÄÌÑ Perl XML::LibXML
24 Summary(zh_CN): XML::LibXML Perl Ä£¿é
25 Name:           perl-%{pdir}-%{pnam}
26 Version:        1.53
27 Release:        3
28 License:        GPL
29 Group:          Development/Languages/Perl
30 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
31 Patch0:         %{name}-Makefile.patch
32 BuildRequires:  libxml2-devel >= 2.4.8
33 BuildRequires:  perl-XML-LibXML-Common
34 BuildRequires:  perl-XML-NamespaceSupport >= 1.07
35 BuildRequires:  perl-XML-SAX >= 0.11
36 BuildRequires:  perl-devel >= 5.6.1
37 BuildRequires:  rpm-perlprov >= 4.0.2-56
38 Requires(post,preun):   perl-XML-LibXML-SAX
39 Requires:       libxml2 >= 2.4.8
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 This module implements much of the DOM Level 2 API as an interface to
44 the Gnome libxml2 library. This makes it a fast and highly capable
45 validating XML parser library, as well as a high performance DOM.
46
47 %description -l pl
48 Ten modu³ to implementacja wiêkszo¶ci API DOM Level 2 jako interfejsu
49 do biblioteki Gnome libxml2. Daje to szybki i o du¿ych mo¿liwo¶ciach
50 parser sprawdzaj±cy poprawno¶æ XML, a tak¿e wysoko wydajny DOM.
51
52 %package SAX
53 Summary:        XML::LibXML::SAX perl module
54 Summary(pl):    Modu³ perla XML::LibXML::SAX
55 Group:          Development/Languages/Perl
56 Requires:       %{name} = %{version}
57
58 %description SAX
59 This class allows you to generate SAX2 events using LibXML. Note that
60 this is not a stream based parser, instead it parses documents into a
61 DOM and traverses the DOM tree. The reason being that libxml2's stream
62 based parsing is extremely primitive, and would require an extreme
63 amount of work to allow SAX2 parsing in a stream manner.
64
65 %description SAX -l pl
66 Ta klasa pozwala generowaæ zdarzenia SAX2 przy u¿yciu LibXML2. To nie
67 jest parser bazuj±cy na strumieniach - przetwarza dokumenty na DOM i
68 nastêpnie wêdruje po drzewie DOM. Wynika to z faktu, ¿e w libxml2
69 parsowanie oparte na strumieniach jest bardzo prymitywne i wymaga³oby
70 wiele pracy, aby umo¿liwiæ strumieniowe parsowanie SAX2.
71
72 %prep
73 %setup -q -n %{pdir}-%{pnam}-%{version}
74 %patch0 -p1
75
76 %build
77 perl Makefile.PL
78 %{__make} OPTIMIZE="%{rpmcflags}"
79
80 # dtd test fails for unknown reason
81 %{?_with_tests:%{__make} test}
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
86
87 %{__make} install DESTDIR=$RPM_BUILD_ROOT
88
89 install example/{*.pl,*.xml,*.dtd,*.xhtml} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
90
91 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/complex
92 install example/complex/{*.xml,*.dtd} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/complex
93
94 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/complex/dtd
95 install example/complex/dtd/*.dtd $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/complex/dtd
96
97 %clean
98 rm -rf $RPM_BUILD_ROOT
99
100 %post SAX
101 perl -MXML::SAX -e "XML::SAX->add_parser(q(XML::LibXML::SAX::Parser))->save_parsers()"
102
103 %preun SAX
104 perl -MXML::SAX -e "XML::SAX->remove_parser(q(XML::LibXML::SAX::Parser))->save_parsers()"
105
106 %files
107 %defattr(644,root,root,755)
108 %doc Changes README
109 %{perl_sitearch}/XML/LibXML.pm
110 %{perl_sitearch}/XML/LibXML/[^S]*.pm
111 %{perl_sitearch}/auto/XML/LibXML/LibXML.bs
112 %attr(755,root,root) %{perl_sitearch}/auto/XML/LibXML/LibXML.so
113 %{_mandir}/man3/XML::LibXML.3pm*
114 %{_mandir}/man3/XML::LibXML::[^S]*
115 %dir %{_examplesdir}/%{name}-%{version}
116 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/x*.pl
117 %{_examplesdir}/%{name}-%{version}/[^x]*
118
119 %files SAX
120 %defattr(644,root,root,755)
121 %dir %{perl_sitearch}/XML/LibXML/SAX
122 %{perl_sitearch}/XML/LibXML/SAX.pm
123 %{perl_sitearch}/XML/LibXML/SAX/*.pm
124 %{_mandir}/man3/XML::LibXML::SAX.3pm*
125 %{_mandir}/man3/XML::LibXML::SAX::*
This page took 0.03183 seconds and 3 git commands to generate.