]> git.pld-linux.org Git - packages/perl-XML-LibXML.git/blob - perl-XML-LibXML.spec
3ee62c3792107bac604bf09897b6f2f7119857f9
[packages/perl-XML-LibXML.git] / perl-XML-LibXML.spec
1 #
2 # Conditional build:
3 # _with_tests - perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    XML
7 %define         pnam    LibXML
8 Summary:        XML::LibXML Perl module
9 Summary(cs):    Modul XML::LibXML pro Perl
10 Summary(da):    Perlmodul XML::LibXML
11 Summary(de):    XML::LibXML Perl Modul
12 Summary(es):    Módulo de Perl XML::LibXML
13 Summary(fr):    Module Perl XML::LibXML
14 Summary(it):    Modulo di Perl XML::LibXML
15 Summary(ja):    XML::LibXML Perl ¥â¥¸¥å¡¼¥ë
16 Summary(ko):    XML::LibXML ÆÞ ¸ðÁÙ
17 Summary(no):    Perlmodul XML::LibXML
18 Summary(pl):    Modu³ Perla XML::LibXML
19 Summary(pt):    Módulo de Perl XML::LibXML
20 Summary(pt_BR): Módulo Perl XML::LibXML
21 Summary(ru):    íÏÄÕÌØ ÄÌÑ Perl XML::LibXML
22 Summary(sv):    XML::LibXML Perlmodul
23 Summary(uk):    íÏÄÕÌØ ÄÌÑ Perl XML::LibXML
24 Summary(zh_CN): XML::LibXML Perl Ä£¿é
25 Name:           perl-%{pdir}-%{pnam}
26 Version:        1.53
27 Release:        2
28 License:        GPL
29 Group:          Development/Languages/Perl
30 Source0:        ftp://ftp.cpan.org/pub/CPAN/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
31 Patch0:         %{name}-Makefile.patch
32 BuildRequires:  libxml2-devel >= 2.4.8
33 BuildRequires:  perl-XML-LibXML-Common
34 BuildRequires:  perl-XML-NamespaceSupport >= 1.07
35 BuildRequires:  perl-XML-SAX >= 0.11
36 BuildRequires:  perl-devel >= 5.6.1
37 BuildRequires:  rpm-perlprov >= 4.0.2-56
38 Requires:       libxml2 >= 2.4.8
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 This module implements much of the DOM Level 2 API as an interface to
43 the Gnome libxml2 library. This makes it a fast and highly capable
44 validating XML parser library, as well as a high performance DOM.
45
46 %description -l pl
47 Ten modu³ to implementacja wiêkszo¶ci API DOM Level 2 jako interfejsu
48 do biblioteki Gnome libxml2. Daje to szybki i o du¿ych mo¿liwo¶ciach
49 parser sprawdzaj±cy poprawno¶æ XML, a tak¿e wysoko wydajny DOM.
50
51 %package SAX
52 Summary:        XML::LibXML::SAX perl module
53 Summary(pl):    Modu³ perla XML::LibXML::SAX
54 Group:          Development/Languages/Perl
55 Requires:       %{name} = %{version}
56
57 %description SAX
58 This class allows you to generate SAX2 events using LibXML. Note that
59 this is not a stream based parser, instead it parses documents into a
60 DOM and traverses the DOM tree. The reason being that libxml2's stream
61 based parsing is extremely primitive, and would require an extreme
62 amount of work to allow SAX2 parsing in a stream manner.
63
64 %description SAX -l pl
65 Ta klasa pozwala generowaæ zdarzenia SAX2 przy u¿yciu LibXML2. To nie
66 jest parser bazuj±cy na strumieniach - przetwarza dokumenty na DOM i
67 nastêpnie wêdruje po drzewie DOM. Wynika to z faktu, ¿e w libxml2
68 parsowanie oparte na strumieniach jest bardzo prymitywne i wymaga³oby
69 wiele pracy, aby umo¿liwiæ strumieniowe parsowanie SAX2.
70
71 %prep
72 %setup -q -n %{pdir}-%{pnam}-%{version}
73 %patch0 -p1
74
75 %build
76 perl Makefile.PL
77 %{__make} OPTIMIZE="%{rpmcflags}"
78
79 # dtd test fails for unknown reason
80 %{?_with_tests:%{__make} test}
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
85
86 %{__make} install DESTDIR=$RPM_BUILD_ROOT
87
88 install example/{*.pl,*.xml,*.dtd,*.xhtml} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
89
90 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/complex
91 install example/complex/{*.xml,*.dtd} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/complex
92
93 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/complex/dtd
94 install example/complex/dtd/*.dtd $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/complex/dtd
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %post SAX
100 perl -MXML::SAX -e "XML::SAX->add_parser(q(XML::LibXML::SAX::Parser))->save_parsers()"
101
102 %preun SAX
103 perl -MXML::SAX -e "XML::SAX->remove_parser(q(XML::LibXML::SAX::Parser))->save_parsers()"
104
105 %files
106 %defattr(644,root,root,755)
107 %doc Changes README
108 %{perl_sitearch}/XML/LibXML.pm
109 %{perl_sitearch}/XML/LibXML/[^S]*.pm
110 %{perl_sitearch}/auto/XML/LibXML/LibXML.bs
111 %attr(755,root,root) %{perl_sitearch}/auto/XML/LibXML/LibXML.so
112 %{_mandir}/man3/XML::LibXML.3pm.gz
113 %{_mandir}/man3/XML::LibXML::[^S]*
114 %dir %{_examplesdir}/%{name}-%{version}
115 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/x*.pl
116 %{_examplesdir}/%{name}-%{version}/[^x]*
117
118 %files SAX
119 %defattr(644,root,root,755)
120 %dir %{perl_sitearch}/XML/LibXML/SAX
121 %{perl_sitearch}/XML/LibXML/SAX.pm
122 %{perl_sitearch}/XML/LibXML/SAX/*.pm
123 %{_mandir}/man3/XML::LibXML::SAX.3pm*
124 %{_mandir}/man3/XML::LibXML::SAX::*
This page took 0.038093 seconds and 3 git commands to generate.