]> git.pld-linux.org Git - packages/perl-XML-LibXML.git/blob - perl-XML-LibXML.spec
- new %%doc and cosmetics
[packages/perl-XML-LibXML.git] / perl-XML-LibXML.spec
1 %include        /usr/lib/rpm/macros.perl
2 %define pdir    XML
3 %define pnam    LibXML
4 Summary:        XML::LibXML perl module
5 Summary(pl):    Modu³ perla XML::LibXML
6 Name:           perl-%{pdir}-%{pnam}
7 Version:        1.51
8 Release:        1
9 License:        GPL
10 Group:          Development/Languages/Perl
11 Source0:        ftp://ftp.cpan.org/pub/CPAN/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
12 Patch0:         %{name}-Makefile.patch
13 BuildRequires:  libxml2-devel >= 2.4.8
14 BuildRequires:  perl-XML-SAX
15 BuildRequires:  perl-devel >= 5.6.1
16 BuildRequires:  rpm-perlprov >= 4.0.2-56
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18 Requires:       libxml2 >= 2.4.8
19
20 %description
21 This module implements much of the DOM Level 2 API as an interface to
22 the Gnome libxml2 library. This makes it a fast and highly capable
23 validating XML parser library, as well as a high performance DOM.
24
25 %description -l pl
26 Ten modu³ to implementacja wiêkszo¶ci API DOM Level 2 jako interfejsu
27 do biblioteki Gnome libxml2. Daje to szybki i o du¿ych mo¿liwo¶ciach
28 parser sprawdzaj±cy poprawno¶æ XML, a tak¿e wysoko wydajny DOM.
29
30 %package SAX
31 Summary:        XML::LibXML-SAX perl module
32 Summary(pl):    Modu³ perla XML::LibXML-SAX
33 Group:          Development/Languages/Perl
34
35 %description SAX
36 This class allows you to generate SAX2 events using LibXML. Note that
37 this is not a stream based parser, instead it parses documents into a
38 DOM and traverses the DOM tree. The reason being that libxml2's stream
39 based parsing is extremely primitive, and would require an extreme
40 amount of work to allow SAX2 parsing in a stream manner.
41
42 %description SAX -l pl
43 Ta klasa pozwala generowaæ zdarzenia SAX2 przy u¿yciu LibXML2. To nie
44 jest parser bazuj±cy na strumieniach - przetwarza dokumenty na DOM i
45 nastêpnie wêdruje po drzewie DOM. Wynika to z faktu, ¿e w libxml2
46 parsowanie oparte na strumieniach jest bardzo prymitywne i wymaga³oby
47 wiele pracy, aby umo¿liwiæ strumieniowe parsowanie SAX2.
48
49 %prep
50 %setup -q -n %{pdir}-%{pnam}-%{version}
51 %patch0 -p1
52
53 %build
54 perl Makefile.PL
55 %{__make} OPTIMIZE="%{rpmcflags}"
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
60
61 %{__make} install DESTDIR=$RPM_BUILD_ROOT
62
63 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
64 install example/{*.pl,*.xml,*.dtd,*.xhtml} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
65
66 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/complex
67 install example/complex/{*.xml,*.dtd} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/complex
68
69 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/complex/dtd
70 install example/complex/dtd/*.dtd $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/complex/dtd
71
72 %post SAX
73 perl -MXML::SAX -e "XML::SAX->add_parser(q(XML::LibXML::SAX::Parser))->save_parsers()"
74
75 %preun SAX
76 perl -MXML::SAX -e "XML::SAX->remove_parser(q(XML::LibXML::SAX::Parser))->save_parsers()"
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %files
82 %defattr(644,root,root,755)
83 %doc Changes README PHISHS.CHANGES
84 %{perl_sitearch}/XML/LibXML.pm
85 %dir %{perl_sitearch}/XML/LibXML
86 %{perl_sitearch}/XML/LibXML/*.pm
87 %{perl_sitearch}/XML/LibXML/*.pod
88 %dir %{perl_sitearch}/auto/XML/LibXML
89 %{perl_sitearch}/auto/XML/LibXML/LibXML.bs
90 %attr(755,root,root) %{perl_sitearch}/auto/XML/LibXML/LibXML.so
91 %{_mandir}/man3/XML::LibXML.3pm.gz
92 %{_mandir}/man3/XML::LibXML::[^S][^A][^X]*
93 %{_examplesdir}/%{name}-%{version}
94
95 %files SAX
96 %defattr(644,root,root,755)
97 %dir %{perl_sitearch}/XML/LibXML/SAX
98 %{perl_sitearch}/XML/LibXML/SAX/*.pm
99 %{_mandir}/man3/XML::LibXML::SAX.3pm.gz
100 %{_mandir}/man3/XML::LibXML::SAX::*
This page took 0.056401 seconds and 3 git commands to generate.