]> git.pld-linux.org Git - packages/perl-XML-Filter-DOMFilter-LibXML.git/blob - perl-XML-Filter-DOMFilter-LibXML.spec
use generic url
[packages/perl-XML-Filter-DOMFilter-LibXML.git] / perl-XML-Filter-DOMFilter-LibXML.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    XML
6 %define         pnam    Filter-DOMFilter-LibXML
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        XML::Filter::DOMFilter::LibXML - SAX filter allowing DOM processing of selected subtrees
9 Summary(pl.UTF-8):      XML::Filter::DOMFilter::LibXML - filtr SAX pozwalający na przetwarzanie DOM wybranych poddrzew
10 Name:           perl-XML-Filter-DOMFilter-LibXML
11 Version:        0.02
12 Release:        3
13 License:        unknown
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  9089d02fbd5ff914070af4c3b9142f02
17 URL:            http://search.cpan.org/dist/XML-Filter-DOMFilter-LibXML/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-XML-LibXML >= 1.53
22 BuildRequires:  perl-XML-LibXML-SAX
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This module provides a compromise between SAX and DOM processing by
29 allowing to use DOM API to process only reasonably small parts of an
30 XML document. It works as a SAX filter temporarily building small DOM
31 trees around parts selected by given XPath expressions (with some
32 limitations).
33
34 %description -l pl.UTF-8
35 Ten moduł daje kompromis pomiędzy przetwarzaniem SAX i DOM zezwalając
36 na używanie API DOM do przetwarzania tylko odpowiednio małych części
37 dokumentu XML. Działa jako filtr SAX tymczasowo budujący małe drzewa
38 DOM dla części wybranych poprzez podane wyrażenia XPath (z pewnymi
39 ograniczeniami).
40
41 %prep
42 %setup -q -n %{pdir}-%{pnam}-%{version}
43
44 %build
45 %{__perl} Makefile.PL \
46         INSTALLDIRS=vendor
47 %{__make}
48
49 %{?with_tests:%{__make} test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %dir %{perl_vendorlib}/XML/Filter/DOMFilter
63 %{perl_vendorlib}/XML/Filter/DOMFilter/*.pm
64 %{_mandir}/man3/*
This page took 0.074713 seconds and 3 git commands to generate.