]> git.pld-linux.org Git - packages/perl-X11-GUITest.git/blob - perl-X11-GUITest.spec
- new
[packages/perl-X11-GUITest.git] / perl-X11-GUITest.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # do perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    X11
7 %define         pnam    GUITest
8 Summary:        X11::GUITest - GUI testing/interaction facilities
9 Name:           perl-X11-GUITest
10 Version:        0.20
11 Release:        0.1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  d175896c876b932e11f5a3ffa313f189
17 BuildRequires:  XFree86-devel
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 This Perl package is intended to facilitate the testing of GUI
24 applications by means of user emulation. It can be used to test/interact
25 with GUI applications; which have been built upon the X library or
26 toolkits (i.e., GTK+, Xt, Qt, Motif, etc.) that "wrap" the X library's
27 functionality.
28
29 %prep
30 %setup -q -n %{pdir}-%{pnam}-%{version}
31
32 %build
33 %{__perl} Makefile.PL \
34         INSTALLDIRS=vendor
35 %{__make}
36
37 %{?with_tests:%{__make} test}
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41
42 %{__make} install \
43         DESTDIR=$RPM_BUILD_ROOT
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %files
49 %defattr(644,root,root,755)
50 %doc README docs/{Changes,ToDo}
51 %dir %{perl_vendorarch}/X11
52 %dir %{perl_vendorarch}/auto/X11
53 %dir %{perl_vendorarch}/auto/X11/GUITest
54 %{perl_vendorarch}/X11/GUITest.pm
55 %attr(755,root,root) %{perl_vendorarch}/auto/X11/GUITest/GUITest.so
56 %{perl_vendorarch}/auto/X11/GUITest/GUITest.bs
57 %{_mandir}/man3/*
This page took 0.074208 seconds and 4 git commands to generate.