]> git.pld-linux.org Git - packages/perl-Wx-GLCanvas.git/blob - perl-Wx-GLCanvas.spec
- rebuild with perl 5.24.0
[packages/perl-Wx-GLCanvas.git] / perl-Wx-GLCanvas.spec
1 #
2 # Conditional build:
3 %bcond_without  unicode # ANSI instead of Unicode version of wxGTK
4 %bcond_with     gtk3    # wxGTK3 instead of wxGTK2
5 %bcond_with     tests   # "make test" (requires $DISPLAY)
6 #
7 %define         wxpkg   wxGTK%{?with_gtk3:3}%{!?with_gtk3:2}%{?with_unicode:-unicode}
8 %define         pdir    Wx
9 %define         pnam    GLCanvas
10 %include        /usr/lib/rpm/macros.perl
11 Summary:        Wx::GLCanvas - interface to wxWidgets' OpenGL canvas
12 Summary(pl.UTF-8):      Wx::GLCanvas - interfejs do "płótna" OpenGL biblioteki wxWidgets
13 Name:           perl-Wx-GLCanvas
14 Version:        0.09
15 Release:        4
16 # same as perl
17 License:        GPL v1+ or Artistic
18 Group:          Development/Languages/Perl
19 Source0:        http://www.cpan.org/modules/by-module/Wx/%{pdir}-%{pnam}-%{version}.tar.gz
20 # Source0-md5:  4f6475010bd6e4231e2dbb3fb52bc642
21 URL:            http://search.cpan.org/dist/Wx-GLCanvas/
22 BuildRequires:  perl-devel >= 1:5.8.0
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 BuildRequires:  perl-Module-Pluggable
25 BuildRequires:  perl(Wx::build::MakeMaker) >= 0.16
26 BuildRequires:  perl-Wx-devel >= 0.57
27 BuildRequires:  %{wxpkg}-devel
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Wx::GLCanvas is an interface to wxWidgets' OpenGL canvas.
32
33 %description -l pl.UTF-8
34 Wx::GLCanvas to interfejs do "płótna" OpenGL biblioteki wxWidgets.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make} \
43         CC="%{__cxx}" \
44         OPTIMIZE="%{rpmcflags}"
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} pure_install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes README.txt
60 %{perl_vendorarch}/Wx/GLCanvas.pm
61 %dir %{perl_vendorarch}/Wx/DemoModules
62 %{perl_vendorarch}/Wx/DemoModules/wxGLCanvas.pm
63 %dir %{perl_vendorarch}/auto/Wx/GLCanvas
64 %attr(755,root,root) %{perl_vendorarch}/auto/Wx/GLCanvas/GLCanvas.so
65 %{_mandir}/man3/Wx::GLCanvas.3pm*
This page took 0.045977 seconds and 3 git commands to generate.