]> git.pld-linux.org Git - SPECS.git/blob - perl-WWW-Google-PageRank.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / perl-WWW-Google-PageRank.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    WWW
6 %define pnam    Google-PageRank
7 Summary:        WWW::Google::PageRank - Query Google pagerank of page
8 Summary(pl.UTF-8):      WWW::Google::PageRank - zapytanie o ranking strony w Google
9 Name:           perl-WWW-Google-PageRank
10 Version:        0.17
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/WWW/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  16437cb7f0f12c3b8529600a93140f38
17 URL:            http://search.cpan.org/dist/WWW-Google-PageRank/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl(LWP::UserAgent)
22 BuildRequires:  perl(URI::Escape)
23 BuildRequires:  perl-URI
24 BuildRequires:  perl-libwww
25 %endif
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 The WWW::Google::PageRank is a class implementing a interface for
31 querying Google pagerank.
32
33 To use it, you should create WWW::Google::PageRank object and use
34 its method get(), to query page rank of URL.
35
36 It uses LWP::UserAgent for making request to Google.
37
38 %description -l pl.UTF-8
39 WWW::Google::PageRank to klasa implementująca interfejs do odpytywania
40 Google o ranking strony.
41
42 Aby go użyć, należy utworzyć obiekt WWW::Google::PageRank i użyć jego
43 metody get() do zapytania o ranking strony o podanym URL-u.
44
45 Klasa używa LWP::UserAgent do wykonywania zapytań do serwisu Google.
46
47 %prep
48 %setup -q -n %{pdir}-%{pnam}-%{version}
49
50 %build
51 %{__perl} Makefile.PL \
52         INSTALLDIRS=vendor
53 %{__make}
54
55 %{?with_tests:%{__make} test}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %{__make} install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc Changes README
69 %{perl_vendorlib}/WWW/Google/*.pm
70 %{_mandir}/man3/*
This page took 0.037794 seconds and 3 git commands to generate.