]> git.pld-linux.org Git - packages/perl-Verilog-Perl.git/blob - perl-Verilog-Perl.spec
- x32 rebuild
[packages/perl-Verilog-Perl.git] / perl-Verilog-Perl.spec
1 # TODO
2 # - should use CXX/CC make options not CC for .cpp compile!
3 # - maybe bin/man1 should be moved to another package
4 #
5 # Conditional build:
6 %bcond_without  tests           # do not perform "make test"
7 #
8 %include        /usr/lib/rpm/macros.perl
9 %define pdir    Verilog
10 %define pnam    Perl
11 Summary:        Verilog::Perl - an Perl way to handle Verilog files
12 Summary(pl.UTF-8):      Verilog::Perl - perlowy sposób obsługi plików Verilog
13 Name:           perl-Verilog-Perl
14 Version:        3.401
15 Release:        4
16 License:        LGPL or Perl Artistic License
17 Group:          Development/Languages/Perl
18 Source0:        http://www.cpan.org/modules/by-module/Verilog/%{pdir}-%{pnam}-%{version}.tar.gz
19 # Source0-md5:  d44e4af50143a50d731fdc8819a33ce6
20 URL:            http://search.cpan.org/dist/Verilog-Perl/
21 BuildRequires:  flex
22 BuildRequires:  perl-devel >= 1:5.8.0
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Verilog::Parser, Verilog::Preproc, and other Perl modules useful for
28 manipulation of Verilog files. The Verilog::Parser package will
29 tokenize a Verilog file when the parse() method is called and invoke
30 various callback methods. This is useful for extracting information
31 and editing files while retaining all context. For netlist like
32 extractions, see Verilog::Netlist. Verilog::Preproc reads Verilog
33 files, and preprocesses them according to the Verilog 2001
34 specification. Programs can be easily converted from reading a
35 IO::File into reading preprocessed output from Verilog::Preproc.
36 Verilog::Netlist contains interconnect information about a whole
37 design database.
38
39 %description -l pl.UTF-8
40 Verilog::Parser, Verilog::Preproc i inne moduły Perla przydatne do
41 obróbki plików Verilog. Pakiet Verilog::Parser po wywołaniu metody
42 parse() zamienia plik Verilog na tokeny i wykonuje różne metody
43 wywołań zwrotnych. Jest to przydatne przy wyciąganiu informacji i
44 modyfikowaniu plików z zachowaniem całego kontekstu. Do wyciągania
45 informacji w stylu netlist można użyć Verilog::Netlist.
46 Verilog::Preproc czyta pliki Verilog i przetwarza je zgodnie ze
47 specyfikacją Verilog 2001. Można łatwo przekształcać programy z
48 odczytu za pomocą IO::File na czytanie przetworzonego wyjścia z
49 Verilog::Preproc. Verilog::Netlist zawiera dołączone informacje o
50 całej bazie projektu.
51
52 %prep
53 %setup -q -n %{pdir}-%{pnam}-%{version}
54
55 %build
56 %{__perl} Makefile.PL \
57         INSTALLDIRS=vendor
58 %{__make} \
59         CC="%{__cxx}" \
60         OPTIMIZE="%{rpmcflags}"
61
62 %{?with_tests:%{__make} test}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 %{__make} install \
68         DESTDIR=$RPM_BUILD_ROOT
69
70 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/Verilog/Verilog-Perl.pod
71 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Verilog/Language/.packlist
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %files
77 %defattr(644,root,root,755)
78 %doc Changes README
79 %attr(755,root,root) %{_bindir}/*
80 %dir %{perl_vendorarch}/Verilog
81 %{perl_vendorarch}/Verilog/*.pm
82 %dir %{perl_vendorarch}/Verilog/Netlist
83 %{perl_vendorarch}/Verilog/Netlist/*.pm
84 %dir %{perl_vendorarch}/auto/Verilog
85 %dir %{perl_vendorarch}/auto/Verilog/Preproc
86 %attr(755,root,root) %{perl_vendorarch}/auto/Verilog/Preproc/Preproc.so
87 %dir %{perl_vendorarch}/auto/Verilog/Parser
88 %attr(755,root,root) %{perl_vendorarch}/auto/Verilog/Parser/Parser.so
89 %{_mandir}/man1/*
90 %{_mandir}/man3/*
This page took 0.062497 seconds and 4 git commands to generate.