]> git.pld-linux.org Git - packages/perl-Verilog-Perl.git/blob - perl-Verilog-Perl.spec
- up to 2.372, rel 0.1
[packages/perl-Verilog-Perl.git] / perl-Verilog-Perl.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Verilog
7 %define pnam    Perl
8 Summary:        perl(Verilog::Perl) - an perl way to handle Verilog files
9 #Summary(pl):   
10 Name:           perl-Verilog-Perl
11 Version:        2.372
12 Release:        0.1
13 License:        LGPL or Perl Artistic License
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  b879520aa1f4b05c01f5cfa2bcdfaa12
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 %if %{with tests}
20 %endif
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Verilog::Parser, Verilog::Preproc, and other perl modules usefull for
25 manipulation of verilog files. The Verilog::Parser package will tokenize a
26 Verilog file when the parse() method is called and invoke various callback
27 methods. This is useful for extracting information and editing files while
28 retaining all context. For netlist like extractions, see Verilog::Netlist.
29 Verilog::Preproc reads Verilog files, and preprocesses them according to the
30 Verilog 2001 specification. Programs can be easily converted from reading a
31 IO::File into reading preprocessed output from Verilog::Preproc.
32 Verilog::Netlist contains interconnect information about a whole design
33 database.
34
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make}
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 # maybe bin/man1 should be moved to another package
56 %files
57 %defattr(644,root,root,755)
58 %doc Changes README
59 %dir %{perl_vendorarch}/Verilog
60 %{perl_vendorarch}/Verilog/*.pm
61 %dir %{perl_vendorarch}/Verilog/Netlist
62 %{perl_vendorarch}/Verilog/Netlist/*.pm
63 %dir %{perl_vendorarch}/auto/Verilog/Preproc
64 %{perl_vendorarch}/auto/Verilog/Preproc/Preproc*
65 %{_mandir}/man3/*
66 %{_mandir}/man1/*
67 %attr(755,root,root) %{_bindir}/*
This page took 0.039481 seconds and 4 git commands to generate.