]> git.pld-linux.org Git - packages/perl-Verilog-Perl.git/blob - perl-Verilog-Perl.spec
- optflags, .so perms
[packages/perl-Verilog-Perl.git] / perl-Verilog-Perl.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Verilog
7 %define pnam    Perl
8 Summary:        Verilog::Perl - an Perl way to handle Verilog files
9 Summary(pl.UTF-8):      Verilog::Perl - perlowy sposób obsługi plików Verilog
10 Name:           perl-Verilog-Perl
11 Version:        2.372
12 Release:        0.1
13 License:        LGPL or Perl Artistic License
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Verilog/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  b879520aa1f4b05c01f5cfa2bcdfaa12
17 URL:            http://search.cpan.org/dist/Verilog-Perl/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Verilog::Parser, Verilog::Preproc, and other Perl modules useful for
24 manipulation of Verilog files. The Verilog::Parser package will
25 tokenize a Verilog file when the parse() method is called and invoke
26 various callback methods. This is useful for extracting information
27 and editing files while retaining all context. For netlist like
28 extractions, see Verilog::Netlist. Verilog::Preproc reads Verilog
29 files, and preprocesses them according to the Verilog 2001
30 specification. Programs can be easily converted from reading a
31 IO::File into reading preprocessed output from Verilog::Preproc.
32 Verilog::Netlist contains interconnect information about a whole
33 design database.
34
35 %description -l pl.UTF-8
36 Verilog::Parser, Verilog::Preproc i inne moduły Perla przydatne do
37 obróbki plików Verilog. Pakiet Verilog::Parser po wywołaniu metody
38 parse() zamienia plik Verilog na tokeny i wykonuje różne metody
39 wywołań zwrotnych. Jest to przydatne przy wyciąganiu informacji i
40 modyfikowaniu plików z zachowaniem całego kontekstu. Do wyciągania
41 informacji w stylu netlist można użyć Verilog::Netlist.
42 Verilog::Preproc czyta pliki Verilog i przetwarza je zgodnie ze
43 specyfikacją Verilog 2001. Można łatwo przekształcać programy z
44 odczytu za pomocą IO::File na czytanie przetworzonego wyjścia z
45 Verilog::Preproc. Verilog::Netlist zawiera dołączone informacje o
46 całej bazie projektu.
47
48 %prep
49 %setup -q -n %{pdir}-%{pnam}-%{version}
50
51 %build
52 %{__perl} Makefile.PL \
53         INSTALLDIRS=vendor
54 %{__make} \
55         OPTIMIZE="%{rpmcflags}"
56
57 %{?with_tests:%{__make} test}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 %{__make} install \
63         DESTDIR=$RPM_BUILD_ROOT
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 # maybe bin/man1 should be moved to another package
69 %files
70 %defattr(644,root,root,755)
71 %doc Changes README
72 %attr(755,root,root) %{_bindir}/*
73 %dir %{perl_vendorarch}/Verilog
74 %{perl_vendorarch}/Verilog/*.pm
75 %dir %{perl_vendorarch}/Verilog/Netlist
76 %{perl_vendorarch}/Verilog/Netlist/*.pm
77 %dir %{perl_vendorarch}/auto/Verilog/Preproc
78 %{perl_vendorarch}/auto/Verilog/Preproc/Preproc.bs
79 %attr(755,root,root) %{perl_vendorarch}/auto/Verilog/Preproc/Preproc.so
80 %{_mandir}/man1/*
81 %{_mandir}/man3/*
This page took 0.037085 seconds and 4 git commands to generate.