]> git.pld-linux.org Git - SPECS.git/blob - perl-Unicode-String.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / perl-Unicode-String.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Unicode
6 %define         pnam    String
7 Summary:        Unicode::String perl module
8 Summary(pl.UTF-8):      Moduł perla Unicode::String
9 Name:           perl-Unicode-String
10 Version:        2.10
11 Release:        3
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Unicode/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  7a8210e673824b9fb90fd1c360483890
17 Patch0:         utf8doc.patch
18 URL:            https://metacpan.org/dist/Unicode-String
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  perl-MIME-Base64 >= 2.00
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildRequires:  rpmbuild(macros) >= 1.745
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Unicode::String Perl module - String of Unicode characters
27 (UCS2/UTF16).
28
29 %description -l pl.UTF-8
30 Moduł Perla Unicode::String - klasa ciągu unikodowych znaków
31 (UCS2/UTF16).
32
33 %prep
34 %setup -q -n %{pdir}-%{pnam}-%{version}
35 %patch0 -p1
36
37 %build
38 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40 %{__make} \
41         CC="%{__cc}" \
42         OPTIMIZE="%{rpmcflags}"
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc Changes README
58 %{perl_vendorarch}/Unicode/CharName.pm
59 %{perl_vendorarch}/Unicode/String.pm
60 %dir %{perl_vendorarch}/auto/Unicode/String
61 %attr(755,root,root) %{perl_vendorarch}/auto/Unicode/String/String.so
62 %{_mandir}/man3/Unicode::CharName.3pm*
63 %{_mandir}/man3/Unicode::String.3pm*
This page took 0.703723 seconds and 3 git commands to generate.