]> git.pld-linux.org Git - packages/perl-URPM.git/blob - perl-URPM.spec
- tabs in preamble
[packages/perl-URPM.git] / perl-URPM.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" (these fail on PLD)
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pnam    URPM
7 %define         pdir    perl-URPM
8 Summary:        URPM - manipulate and manage rpm files, hdlist files and rpm header files
9 Summary(pl.UTF-8):      URPM - manipulowanie i zarządzanie plikami rpm, hdlist i nagłówkami rpm
10 Name:           perl-URPM
11 Version:        1.47
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-authors/id/R/RG/RGARCIA/%{pnam}-%{version}.tar.gz
17 # Source0-md5:  aac0b2a6274dfbf4c1acdd59d30f7c8c
18 URL:            http://search.cpan.org/dist/URPM/
19 BuildRequires:  bzip2-devel
20 BuildRequires:  packdrake
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-devel >= 4.2.3
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 The URPM module allows you to manipulate rpm files, rpm header files,
28 hdlist files and manage them in memory.
29
30 %description -l pl.UTF-8
31 Moduł URPM pozwala na manipulowanie plikami rpm, nagłówkami plików
32 rpm, plikami hdlist oraz zarządzanie nimi w pamięci.
33
34 %prep
35 %setup -q -n %{pnam}-%{version}
36
37 %build
38 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40 %{__make} \
41         OPTIMIZE="%{rpmcflags}"
42
43 %{?with_tests:%{__make} test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} pure_install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc README ChangeLog
57 %{_mandir}/man3/*
58 %{perl_vendorarch}/URPM
59 %{perl_vendorarch}/URPM.pm
60 %dir %{perl_vendorarch}/auto/URPM
61 %attr(755,root,root) %{perl_vendorarch}/auto/URPM/URPM.so
62 %{perl_vendorarch}/auto/URPM/URPM.bs
This page took 0.083245 seconds and 3 git commands to generate.