]> git.pld-linux.org Git - packages/perl-URI.git/blob - perl-URI.spec
- formatting
[packages/perl-URI.git] / perl-URI.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    URI
7 %define         pnam    URI
8 Summary:        URI - Uniform Resource Identifiers (absolute and relative)
9 Summary(pl):    URI - obs³uga ujednoliconych identyfikatorów zasobów (bezwzglêdnych i wzglêdnych)
10 Summary(ru):    URI - Uniform Resource Identifier (URI) ÓÓÙÌËÉ, ËÁË ÕËÁÚÙ×ÁÅÔ RFC 2396
11 Summary(uk):    URI - ÐÏÓÉÌÁÎÎÑ Uniform Resource Identifier (URI) ÑË ×ÉÚÎÁÞÅÎÏ × RFC 2396
12 Name:           perl-URI
13 Version:        1.34
14 Release:        1
15 # same as perl
16 License:        GPL v1+ or Artistic
17 Group:          Development/Languages/Perl
18 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pnam}-%{version}.tar.gz
19 # Source0-md5:  78528742ce086b155b19cfcbc67429c2
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 %if %{with tests}
23 BuildRequires:  perl-MIME-Base64
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         _noautoreq      'perl(Business::ISBN)'
29
30 %description
31 This package contains the URI.pm module with friends. The module
32 implements the URI class. Objects of this class represent Uniform
33 Resource Identifier (URI) references as specified in RFC 2396.
34
35 %description -l ru
36 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ URI.pm É ÓÏÐÕÔÓÔ×ÕÀÝÉÅ ÍÏÄÕÌÉ. íÏÄÕÌØ ÒÅÁÌÉÚÕÅÔ
37 Uniform Resource Identifier (URI) ÓÓÙÌËÉ, ËÁË ÕËÁÚÙ×ÁÅÔ RFC 2396.
38
39 %description -l pl
40 Ten pakiet zawiera modu³ URI dla Perla. S³u¿y on do obróbki
41 ujednoliconych identyfikatorów zasobów (URI - Uniform Resource
42 Identifier), zgodnych z RFC 2396.
43
44 %description -l pt_BR
45 Módulo Perl URI - Este pacote contém o modulo URI.pm para manipular
46 "Uniform Resource Identifier" (URI) confirme especificado na RFC 2396.
47
48 %description -l uk
49 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ URI.pm ÔÁ ÐÏÔÒ¦ÂΦ ÄÌÑ ÎØÏÇÏ ÍÏÄÕ̦. íÏÄÕÌØ ÒÅÁ̦ÚÕ¤
50 ÐÏÓÉÌÁÎÎÑ Uniform Resource Identifier (URI) ÑË ÚÁÚÎÁÞÅÎÏ × RFC 2396.
51
52 %prep
53 %setup -q -n %{pnam}-%{version}
54 mv t/heuristic.t{,.blah}
55
56 %build
57 %{__perl} Makefile.PL \
58         INSTALLDIRS=vendor
59 %{__make}
60
61 %{?with_tests:%{__make} test}
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65
66 %{__make} install \
67         DESTDIR=$RPM_BUILD_ROOT
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files
73 %defattr(644,root,root,755)
74 %doc README Changes
75 %{perl_vendorlib}/URI
76 %{perl_vendorlib}/*.pm
77 %{_mandir}/man3/*
This page took 0.039377 seconds and 3 git commands to generate.