]> git.pld-linux.org Git - packages/perl-UNIVERSAL-require.git/blob - perl-UNIVERSAL-require.spec
39a3fddc95361d91ed4a419082540550ec85058d
[packages/perl-UNIVERSAL-require.git] / perl-UNIVERSAL-require.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    UNIVERSAL
7 %define pnam    require
8 Summary:        UNIVERSAL::require - require() modules from a variable
9 Summary(pl.UTF-8):      UNIVERSAL::require - wymaganie modułów ze zmiennej
10 Name:           perl-UNIVERSAL-require
11 Version:        0.13
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/UNIVERSAL/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  e6ea431fac9524077414d531a8cc203c
18 URL:            http://search.cpan.org/dist/UNIVERSAL-require/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 Conflicts:      perl-UNIVERSAL-exports < 0.03-3
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 If you've ever had to do this...
27
28 eval "require $module";
29
30 to get around the bareword caveats on require(), this module is for
31 you. It creates a universal require() class method that will work with
32 every Perl module and it's secure. So instead of doing some arcane
33 eval() work, you can do this:
34
35 $module->require;
36
37 %description -l pl.UTF-8
38 Jeśli kiedykolwiek było nam potrzebne...
39
40 eval "require $module";
41
42 do obejścia przeciwności require(), ten moduł jest dla nas. Tworzy
43 uniwersalną metodę klasy require() działającą z każdym modułem Perla,
44 a jednocześnie bezpieczną. Czyli zamiast wykonywania jakichś tajemnych
45 działań z eval(), można zrobić:
46
47 $module->require;
48
49 %prep
50 %setup -q -n %{pdir}-%{pnam}-%{version}
51
52 %build
53 %{__perl} Makefile.PL \
54         INSTALLDIRS=vendor
55 %{__make}
56
57 %{?with_tests:%{__make} test}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 %{__make} install \
63         DESTDIR=$RPM_BUILD_ROOT
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc Changes
71 %{perl_vendorlib}/UNIVERSAL/*.pm
72 %{_mandir}/man3/*
This page took 0.17233 seconds and 3 git commands to generate.