]> git.pld-linux.org Git - SPECS.git/blob - perl-Tree-Binary.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / perl-Tree-Binary.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    Tree
6 %define pnam    Binary
7 Summary:        Tree::Binary - A Object Oriented Binary Tree for Perl
8 #Summary(pl.UTF-8):     
9 Name:           perl-Tree-Binary
10 Version:        0.07
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Tree/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  a5f9a000a7accc4550965892ba80952f
17 URL:            http://search.cpan.org/dist/Tree-Binary/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 This module is a fully object oriented implementation of a binary
25 tree. Binary trees are a specialized type of tree which has only
26 two possible branches, a left branch and a right branch. While it
27 is possible to use an n-ary tree, like Tree::Simple, to fill most of
28 your binary tree needs, a true binary tree object is just easier to
29 mantain and use.
30
31 # %description -l pl.UTF-8
32 # TODO
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36
37 %build
38 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40 %{__make}
41
42 %{?with_tests:%{__make} test}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %{__make} pure_install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc Changes README
56 %{perl_vendorlib}/Tree/*.pm
57 %{perl_vendorlib}/Tree/Binary
58 %{_mandir}/man3/*
This page took 0.586708 seconds and 3 git commands to generate.