]> git.pld-linux.org Git - SPECS.git/blob - perl-Tie-Tk-Text.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / perl-Tie-Tk-Text.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # perform "make test", requires DISPLAY
4
5 %define         pdir    Tie
6 %define         pnam    Tk-Text
7 Summary:        Tie::Tk::Text - Access Tk text widgets as arrays
8 Name:           perl-Tie-Tk-Text
9 Version:        0.92
10 Release:        1
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Tie/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  9e2064a300a46f2df81df5383c24f068
16 URL:            http://search.cpan.org/dist/Tie-Tk-Text/
17 BuildRequires:  perl-Module-Build
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Tk
22 %endif
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This module defines a class for tie()ing Tk text widgets to an array,
28 allowing them to be accessed as if they were an array of lines.
29
30 It's not expected that anyone will actually want to populate and
31 manipulate their text widgets this way, though you are of course free
32 to do so. This module was created to make text widgets accessible to
33 functions that expect an array reference as their input. (e.g.
34 Algorithm::Diff::sdiff) You can do that with read-only support (FETCH
35 and FETCHSIZE). All of the methods (PUSH, POP, STORE, etc.) are
36 included for completeness.
37
38 Note: This documentation refers to "Tk text" widgets rather than
39 "Tk::Text" ones. That's because it supports anything that uses the
40 same API as a Tk text widget. It works with Perl/Tk and Tkx and should
41 work with Tcl::Tk as well.
42
43 %prep
44 %setup -q -n %{pdir}-%{pnam}-%{version}
45
46 %build
47 %{__perl} Build.PL \
48         destdir=$RPM_BUILD_ROOT \
49         installdirs=vendor
50 ./Build
51
52 %{?with_tests:./Build test}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56 ./Build install
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc Changes README
64 %dir %{perl_vendorlib}/Tie/Tk
65 %{perl_vendorlib}/Tie/Tk/Text.pm
66 %{_mandir}/man3/Tie::Tk::Text.3pm*
This page took 0.584837 seconds and 3 git commands to generate.