]> git.pld-linux.org Git - SPECS.git/blob - perl-Tie-RefHash.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / perl-Tie-RefHash.spec
1 #
2 # Conditional build:
3 %bcond_without  autodeps        # don't BR packages needed only for resolving deps
4 %bcond_without  tests           # do not perform "make test"
5
6 %define         pdir    Tie
7 %define         pnam    RefHash
8 Summary:        Tie::RefHash - use references as hash keys
9 Name:           perl-Tie-RefHash
10 Version:        1.39
11 Release:        2
12 # even cpan dont know license
13 License:        unknown
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Tie/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  179d4d02924bd9716e2ffe585cbd36c8
17 URL:            http://search.cpan.org/dist/Tie-RefHash/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 This module provides the ability to use references as hash keys if you
25 first tie the hash variable to this module. Normally, only the keys of
26 the tied hash itself are preserved as references; to use references as
27 keys in hashes-of-hashes, use Tie::RefHash::Nestable, included as part
28 of Tie::RefHash.
29
30 It is implemented using the standard perl TIEHASH interface. Please
31 see the tie entry in perlfunc(1) and perltie(1) for more information.
32
33 The Nestable version works by looking for hash references being stored
34 and converting them to tied hashes so that they too can have
35 references as keys. This will happen without warning whenever you
36 store a reference to one of your own hashes in the tied hash.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make}
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 install -d $RPM_BUILD_ROOT%{perl_vendorlib}/Tie/RefHash
51
52 %{__make} pure_install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Changes
61 %{perl_vendorlib}/Tie/RefHash.pm
62 %dir %{perl_vendorlib}/Tie/RefHash
63 %{_mandir}/man3/Tie::RefHash.3pm*
This page took 0.847038 seconds and 3 git commands to generate.