]> git.pld-linux.org Git - packages/perl-Tie-Cache.git/blob - perl-Tie-Cache.spec
696d69b18d1162e47f768134607f5c80b3337c01
[packages/perl-Tie-Cache.git] / perl-Tie-Cache.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Tie
7 %define         pnam    Cache
8 Summary:        Tie::Cache - LRU Cache in Memory
9 Summary(pl):    Tie::Cache - cache typu LRU w pamiêci
10 Name:           perl-Tie-Cache
11 Version:        0.17
12 Release:        6
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  93f1bb8006815ade24fde309925cebe0
18 Patch0:         %{name}-paths.patch
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 This module implements a least recently used (LRU) cache in memory
26 through a tie interface. Any time data is stored in the tied hash,
27 that key/value pair has an entry time associated with it, and as the
28 cache fills up, those members of the cache that are the oldest are
29 removed to make room for new entries.
30
31 %description -l pl
32 Ten modu³ jest implementacj± cache typu LRU (ostatnio u¿ywane) w
33 pamiêci poprzez powi±zany interfejs. Wszytkie dane dotycz±ce czasu s±
34 zapisywane w powi±zanym haszu, którego para klucz/warto¶æ ma
35 przydzielony wpis dotycz±cy czasu. Kiedy cache siê zape³nia, te
36 najstarsze elementy s± usuwane, aby zrobiæ miejsce nowym.
37
38 %package bench
39 Summary:        Berchmark comparing Tie::Cache and Tie::Cache::LRU Perl modules
40 Summary(pl):    Porównanie wydajno¶ci modu³ów Perla Tie::Cache i Tie::Cache::LRU
41 Group:          Development/Languages/Perl
42
43 %description bench
44 Berchmark comparing Tie::Cache and Tie::Cache::LRU Perl modules.
45
46 %description bench -l pl
47 Porównanie wydajno¶ci modu³ów Perla Tie::Cache i Tie::Cache::LRU.
48
49 %prep
50 %setup -q -n %{pdir}-%{pnam}-%{version}
51 %patch -p1
52
53 %build
54 %{__perl} Makefile.PL \
55         INSTALLDIRS=vendor
56 %{__make}
57
58 %{?with_tests:%{__make} test}
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 %{__make} install \
64         DESTDIR=$RPM_BUILD_ROOT
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc CHANGES README
72 %{perl_vendorlib}/Tie/Cache.pm
73 %{_mandir}/man3/*
74
75 %files bench
76 %defattr(644,root,root,755)
77 %attr(755,root,root) %{perl_vendorlib}/Tie/bench.pl
This page took 0.073856 seconds and 3 git commands to generate.