]> git.pld-linux.org Git - packages/perl-Throwable.git/blob - perl-Throwable.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Throwable.git] / perl-Throwable.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    Throwable
6 Summary:        Throwable - a role for classes that can be thrown
7 Name:           perl-Throwable
8 Version:        0.200013
9 Release:        1
10 # same as perl
11 License:        GPL v1+ or Artistic
12 Group:          Development/Languages/Perl
13 Source0:        http://www.cpan.org/modules/by-authors/id/R/RJ/RJBS/Throwable-%{version}.tar.gz
14 # Source0-md5:  92d4934f601c2d291a65b0bf2ab08dd3
15 URL:            https://github.com/rjbs/Throwable
16 BuildRequires:  perl-devel >= 1:5.8.0
17 BuildRequires:  rpm-perlprov >= 4.1-13
18 %if %{with tests}
19 BuildRequires:  perl-Class-Method-Modifiers
20 BuildRequires:  perl-Devel-StackTrace >= 1.32
21 BuildRequires:  perl-Module-Runtime >= 0.002
22 BuildRequires:  perl-Moo
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Throwable is a role for classes that are meant to be thrown as
29 exceptions to standard program flow. It is very simple and does only
30 two things: saves any previous value for $@ and calls die $self.
31
32 Throwable is implemented with Moo, so you can stick to Moo or use
33 Moose, as you prefer.
34
35 %prep
36 %setup -q -n %{pdir}-%{version}
37
38 %build
39 %{__perl} Makefile.PL \
40         INSTALLDIRS=vendor
41 %{__make}
42
43 %{?with_tests:%{__make} test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 %{__make} pure_install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc Changes README
56 %{perl_vendorlib}/*.pm
57 %{perl_vendorlib}/StackTrace
58 %{perl_vendorlib}/Throwable
59 %{_mandir}/man3/*
This page took 0.072159 seconds and 3 git commands to generate.