]> git.pld-linux.org Git - packages/perl-Throwable.git/blob - perl-Throwable.spec
0191c41df8888e374c219c8d5e443ae2601ad4a2
[packages/perl-Throwable.git] / perl-Throwable.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    Throwable
6 %include        /usr/lib/rpm/macros.perl
7 Summary:        Throwable - a role for classes that can be thrown
8 Name:           perl-Throwable
9 Version:        0.200013
10 Release:        1
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-authors/id/R/RJ/RJBS/Throwable-%{version}.tar.gz
15 # Source0-md5:  92d4934f601c2d291a65b0bf2ab08dd3
16 URL:            https://github.com/rjbs/Throwable
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 %if %{with tests}
20 BuildRequires:  perl-Class-Method-Modifiers
21 BuildRequires:  perl-Devel-StackTrace >= 1.32
22 BuildRequires:  perl-Module-Runtime >= 0.002
23 BuildRequires:  perl-Moo
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Throwable is a role for classes that are meant to be thrown as
30 exceptions to standard program flow. It is very simple and does only
31 two things: saves any previous value for $@ and calls die $self.
32
33 Throwable is implemented with Moo, so you can stick to Moo or use
34 Moose, as you prefer.
35
36 %prep
37 %setup -q -n %{pdir}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make}
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 %{__make} pure_install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc Changes README
57 %{perl_vendorlib}/*.pm
58 %{perl_vendorlib}/StackTrace
59 %{perl_vendorlib}/Throwable
60 %{_mandir}/man3/*
This page took 0.020863 seconds and 2 git commands to generate.