]> git.pld-linux.org Git - packages/perl-Text-VimColor.git/blob - perl-Text-VimColor.spec
14a99290f7eaec15f98e4d1af2c84fb76ead87c4
[packages/perl-Text-VimColor.git] / perl-Text-VimColor.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Text
7 %define         pnam    VimColor
8 Summary:        Text::VimColor - syntax color text in HTML or XML using Vim
9 Summary(pl.UTF-8):      Text::VimColor - kolorowanie składni tekstu w HTML-u lub XML-u przy użyciu Vima
10 Name:           perl-Text-VimColor
11 Version:        0.11
12 Release:        3
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  268fb3f630b463fcec528d798dcf77c3
18 %if %{with tests}
19 BuildRequires:  perl-Path-Class
20 BuildRequires:  vim
21 %endif
22 BuildRequires:  perl-devel >= 1:5.8.0
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This module tries to markup text files according to their syntax. It
29 can be used to produce web pages with pretty-printed colourful source
30 code samples. It can produce output in the following formats:
31 - HTML 
32  Valid XHTML 1.0, with the exact colouring and style left to a CSS
33  stylesheet
34 - XML 
35  Pieces of text are marked with XML elements in a simple vocabulary,
36  which can be converted to other formats, for example, using XSLT
37 - Perl array 
38  A simple Perl data structure, so that Perl code can be used to turn
39  it into whatever is needed
40 This module works by running the Vim text editor and getting it to
41 apply its excellent syntax highlighting (aka 'font-locking') to an
42 input file, and mark pieces of text according to whether it thinks
43 they are comments, keywords, strings, etc.
44
45 %description -l pl.UTF-8
46 Ten moduł próbuje oznaczyć pliki tekstowe zgodnie z ich składnią. Może
47 być używany do tworzenia stron WWW z ładnie wydrukowanymi, kolorowymi
48 przykładami kodu źródłowego. Moduł może tworzyć wynik w następujących
49 formatach:
50 - HTML - poprawny XHTML 1.0, z dokładnym kolorowaniem i stylem
51   pozostawionym dla arkusza CSS
52 - XML - fragmenty tekstu oznaczane elementami XML-a z prostym
53   słownictwem; można to skonwertować do innych formatów, na przykład
54   przy użyciu XSLT
55 - tablica perlowa - prosta struktura danych w Perlu, dzięki czemu
56   można użyć perlowego kodu do przekształcenia jej w co tylko
57   potrzeba.
58 Ten moduł działa poprzez uruchomienie edytora tekstu Vim i zmuszenie
59 go do zastosowania swojego świetnego podświetlania składni (znanego
60 także jako 'font-locking') dla pliku wejściowego oraz oznaczenia
61 fragmentów tekstu zależnie od tego, czy uważa je za komentarze, słowa
62 kluczowe, łańcuchy itp.
63
64 %prep
65 %setup -q -n %{pdir}-%{pnam}-%{version}
66
67 %build
68 %{__perl} Makefile.PL \
69         INSTALLDIRS=vendor
70 %{__make}
71
72 %{?with_tests:%{__make} test}
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76
77 %{__make} install \
78         DESTDIR=$RPM_BUILD_ROOT
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %files
84 %defattr(644,root,root,755)
85 %doc ChangeLog README
86 %attr(755,root,root) %{_bindir}/*
87 %{perl_vendorlib}/Text/*
88 %{_mandir}/man3/*
89 %{_mandir}/man1/*
This page took 0.089906 seconds and 2 git commands to generate.