]> git.pld-linux.org Git - packages/perl-Text-PDF.git/blob - perl-Text-PDF.spec
use generic url
[packages/perl-Text-PDF.git] / perl-Text-PDF.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Text
6 %define         pnam    PDF
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Text::PDF perl module
9 Summary(pl.UTF-8):      Moduł perla Text::PDF
10 %define         base_version    0.29
11 Name:           perl-Text-PDF
12 Version:        %{base_version}a
13 Release:        1
14 # one module mentions License=Artistic
15 License:        Artistic
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
18 # Source0-md5:  2fdf4c3170e53a083715888237914a9b
19 Patch0:         %{name}-fix.patch
20 URL:            http://search.cpan.org/dist/Text-PDF/
21 BuildRequires:  perl-Compress-Zlib
22 BuildRequires:  perl-Font-TTF
23 BuildRequires:  perl-devel >= 1:5.8.0
24 BuildRequires:  rpm-perlprov >= 4.1-13
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Text::PDF - PDF manipulation module.
30
31 %description -l pl.UTF-8
32 Text::PDF umożliwia operowanie na plikach PDF.
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{base_version}
36 %patch0 -p1
37
38 %build
39 %{__perl} Makefile.PL \
40         INSTALLDIRS=vendor
41 %{__make}
42
43 %{?with_tests:%{__make} test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc *txt lib/Text/PDF/changes
57 %attr(755,root,root) %{_bindir}/*
58 %{perl_vendorlib}/Text/PDF.pm
59 %dir %{perl_vendorlib}/Text/PDF
60 %{perl_vendorlib}/Text/PDF/*.pm
61 %{_mandir}/man3/*
This page took 0.072978 seconds and 4 git commands to generate.