]> git.pld-linux.org Git - packages/perl-Text-Glob.git/blob - perl-Text-Glob.spec
f5449c46971756853914fc3a93600f3e7eb93d63
[packages/perl-Text-Glob.git] / perl-Text-Glob.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Text
7 %define         pnam    Glob
8 Summary:        Text::Glob perl module - match globbing patterns against text
9 Summary(pl):    Modu³ perla Text::Glob - dopasowywanie tekstu do wzorców
10 Name:           perl-Text-Glob
11 Version:        0.06
12 Release:        1
13 License:        GPL or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  800d5a40b2f0c7514c58d736d21f616c
17 BuildRequires:  perl-devel >= 5.6
18 %if %{with tests}
19 BuildRequires:  perl-Test-Simple
20 %endif
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Text::Glob implements glob(3) style matching that can be used to match
27 against text, rather than fetching names from a filesystem. If you
28 want to do full file globbing use the File::Glob module instead.
29
30 %description -l pl
31 Text::Glob jest implementacj± dopasowywania w stylu glob(3), które
32 mo¿e byæ u¿ywane do dopasowywania tekstu, a nie nazw plików. Je¶li
33 potrzeba pe³nej implementacji glob dla plików, nale¿y u¿yæ modu³u
34 File::Glob zamiast tego.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make}
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc Changes
58 %{perl_vendorlib}/Text/*.pm
59 %{_mandir}/man3/*
This page took 0.026912 seconds and 2 git commands to generate.