]> git.pld-linux.org Git - SPECS.git/blob - perl-Text-Bidi.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / perl-Text-Bidi.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    Text
6 %define pnam    Bidi
7 Summary:        Text::Bidi - Unicode bidi algorithm using libfribidi
8 Summary(pl.UTF-8):      Text::Bidi - algorytm Unicode bidi z użyciem libfribidi
9 Name:           perl-Text-Bidi
10 Version:        0.03
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Text/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  93e124628ff2983e32ac478f25f8d627
17 URL:            http://search.cpan.org/dist/Text-Bidi/
18 BuildRequires:  fribidi-devel >= 0.10.9
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 This is a Perl interface to the libfribidi library that implements the
25 Unicode bidi algorithm. The bidi algorithm is a specification for
26 displaying text that consists of both left-to-right and right-to-left
27 written languages.
28
29 %description -l pl.UTF-8
30 Ten moduł jest perlowym interfejsem do biblioteki libfribidi
31 implementującej algorytm Unicode bidi. Algorytm bidi jest specyfikacją
32 wyświetlania tekstu zawierającego tekst zarówno w językach pisanych od
33 lewej do prawej, jak i od prawej do lewej.
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37
38 %build
39 %{__perl} Makefile.PL \
40         INSTALLDIRS=vendor
41 %{__make} \
42         CC="%{__cc}" \
43         OPTIMIZE="%{rpmcflags}"
44
45 %{?with_tests:%{__make} test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} pure_install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc Changes README
59 %{perl_vendorarch}/Text/Bidi.pm
60 %dir %{perl_vendorarch}/Text/Bidi
61 %{perl_vendorarch}/Text/Bidi/*.pm
62 %dir %{perl_vendorarch}/auto/Text/Bidi
63 %dir %{perl_vendorarch}/auto/Text/Bidi/private
64 %attr(755,root,root) %{perl_vendorarch}/auto/Text/Bidi/private/*.so
65 %{_mandir}/man3/Text::Bidi.3pm*
66 %{_mandir}/man3/Text::Bidi::CapRTL.3pm*
This page took 0.082437 seconds and 3 git commands to generate.