]> git.pld-linux.org Git - SPECS.git/blob - perl-Test-Script.spec
SPECS updated Tue 30 Apr 15:06:09 CEST 2024
[SPECS.git] / perl-Test-Script.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Test
6 %define         pnam    Script
7 Summary:        Test::Script - Cross-platform basic tests for scripts
8 Summary(pl.UTF-8):      Test::Script - wieloplatformowe podstawowe testy dla skryptów
9 Name:           perl-Test-Script
10 Version:        1.29
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  cadfb1d1fdc421e338521e373d7a9eb7
17 URL:            https://metacpan.org/release/Test-Script
18 BuildRequires:  perl-ExtUtils-MakeMaker
19 BuildRequires:  perl-devel >= 1:5.8.1
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRequires:  rpmbuild(macros) >= 1.745
22 %if %{with tests}
23 BuildRequires:  perl(File::Spec) >= 0.80
24 BuildRequires:  perl-Capture-Tiny
25 BuildRequires:  perl-Probe-Perl >= 0.01
26 BuildRequires:  perl-Test-Simple >= 1.302015
27 BuildRequires:  perl-Test2-Suite >= 0.000060
28 BuildRequires:  perl-Text-ParseWords
29 %endif
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 The intent of this module is to provide a series of basic tests for
35 scripts in the bin directory of your Perl distribution. Further, it
36 aims to provide them with perfect platform-compatibility and in a way
37 that is as unobtrusive as possible. That is, if the program works on a
38 platform, then Test::Script should also work on that platform. In
39 doing so, it is hoped that Test::Script can become a module that you
40 can safely make a dependency of your module, without risking your
41 module not working on some platform because of the dependency. Where a
42 clash exists between wanting more functionality and maintaining
43 platform safety, this module will err on the side of platform safety.
44
45 %description -l pl.UTF-8
46 Przeznaczeniem tego modułu jest zapewnienie serii podstawowych testów
47 dla skryptów z katalogu bin pakietu perlowego. Ponadto ma na celu
48 udostępnienie im doskonałej kompatybilności z platformami w możliwie
49 niekłopotliwy sposób. Oznacza to, że jeśli program działa na jakiejś
50 platformie, Test::Script także powinien na tej platformie działać.
51 Przy tym Test::Script powinien stać się modułem, który bezpiecznie
52 można uczynić zależnością własnego modułu bez ryzykowania, że moduł
53 przestanie działać na jakiejś platformie z powodu tej zależności. Tam,
54 gdzie występuje kolizja między większą funkcjonalnością a zachowaniem
55 zgodności z platformą, ten moduł stanie po stronie zgodności.
56
57 %prep
58 %setup -q -n %{pdir}-%{pnam}-%{version}
59
60 %build
61 %{__perl} Makefile.PL \
62         INSTALLDIRS=vendor
63 %{__make}
64
65 %{?with_tests:%{__make} test}
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69
70 %{__make} install \
71         DESTDIR=$RPM_BUILD_ROOT
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %files
77 %defattr(644,root,root,755)
78 %doc Changes
79 %{perl_vendorlib}/Test/Script.pm
80 %{_mandir}/man3/Test::Script.3pm*
This page took 0.085555 seconds and 3 git commands to generate.