]> git.pld-linux.org Git - packages/perl-Test-Manifest.git/blob - perl-Test-Manifest.spec
- should be ready for perl-5.8.0; release++
[packages/perl-Test-Manifest.git] / perl-Test-Manifest.spec
1 #
2 # Conditional build:
3 # _without_tests - do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Test
7 %define pnam    Manifest
8 Summary:        Test::Manifest - interact with a t/test_manifest file
9 Summary(pl):    Test::Manifest - wspó³praca z plikiem t/test_manifest
10 Name:           perl-Test-Manifest
11 Version:        0.91
12 Release:        2
13 License:        GPL/Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 BuildRequires:  perl >= 5.6
17 BuildRequires:  rpm-perlprov >= 4.1-13
18 %if %{?_without_tests:0}%{!?_without_tests:1}
19 BuildRequires:  perl-Test-Simple
20 %endif
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 MakeMaker assumes that you want to run all of the .t files in the t/
26 directory in ascii-betical order during make test unless you say
27 otherwise.  This leads to some interesting naming schemes for test files
28 to get them in the desired order.
29
30 %description -l pl
31 MakeMaker zak³ada, ¿e chcemy podczas make test uruchamiaæ wszystkie
32 pliki .t z katalogu t/ w kolejno¶ci asciibetycznej, o ile nie podamy
33 innej kolejno¶ci. To prowadzi do interesuj±cych schematów nazywania
34 plików z testami, aby by³y wykonywane we w³a¶ciwej kolejno¶ci.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor 
42 %{__make}
43
44 %{!?_without_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} install DESTDIR=$RPM_BUILD_ROOT
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %{perl_vendorlib}/Test/*.pm
57 %{_mandir}/man3/*
This page took 0.118077 seconds and 3 git commands to generate.