]> git.pld-linux.org Git - packages/perl-Test-Manifest.git/blob - perl-Test-Manifest.spec
- more verbose files
[packages/perl-Test-Manifest.git] / perl-Test-Manifest.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Test
7 %define         pnam    Manifest
8 Summary:        Test::Manifest - interact with a t/test_manifest file
9 Summary(pl.UTF-8):      Test::Manifest - współpraca z plikiem t/test_manifest
10 Name:           perl-Test-Manifest
11 Version:        1.23
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  81c8744987b67d35af05a74a3c7f1742
18 URL:            http://search.cpan.org/dist/Test-Manifest/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Test-Simple
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 MakeMaker assumes that you want to run all of the .t files in the t/
29 directory in ascii-betical order during make test unless you say
30 otherwise. This leads to some interesting naming schemes for test
31 files to get them in the desired order.
32
33 %description -l pl.UTF-8
34 MakeMaker zakłada, że chcemy podczas make test uruchamiać wszystkie
35 pliki .t z katalogu t/ w kolejności asciibetycznej, o ile nie podamy
36 innej kolejności. To prowadzi do interesujących schematów nazywania
37 plików z testami, aby były wykonywane we właściwej kolejności.
38
39 %prep
40 %setup -q -n %{pdir}-%{pnam}-%{version}
41
42 %build
43 %{__perl} Makefile.PL \
44         INSTALLDIRS=vendor
45 %{__make}
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %{perl_vendorlib}/Test/Manifest.pm
This page took 0.072156 seconds and 3 git commands to generate.