]> git.pld-linux.org Git - packages/perl-Test-Inter.git/blob - perl-Test-Inter.spec
d92da44f226f02a3f824d33115415abe88945c2f
[packages/perl-Test-Inter.git] / perl-Test-Inter.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Test
6 %define         pnam    Inter
7 Summary:        Test::Inter - framework for more readable interactive test scripts
8 Summary(pl.UTF-8):      Test::Inter - szkielet dla bardziej czytelnych, interaktywnych skryptów testowych
9 Name:           perl-Test-Inter
10 Version:        1.03
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Test/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  02705664dc874bc8b59b9b313a7572f5
17 URL:            http://search.cpan.org/dist/Test-Inter/
18 BuildRequires:  perl-Module-Build
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 This is another framework for writing test scripts. It is loosely
26 inspired by Test::More, and has most of it's functionality, but it is
27 not a drop-in replacement.
28
29 %description -l pl.UTF-8
30 Ten moduł to jeszcze jeden szkielet do tworzenia skryptów testowych.
31 Jest luźno inspirowany modułem Test::More i ma większość jego
32 funkcjonalności, ale nie jest bezpośrednim zamiennikiem.
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36
37 %build
38 %{__perl} Build.PL \
39         destdir=$RPM_BUILD_ROOT \
40         installdirs=vendor
41 ./Build
42
43 %{?with_tests:./Build test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 ./Build install
49
50 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
51 cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
52 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/Test/Inter.pod
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc ChangeLog LICENSE TODO
60 %{perl_vendorlib}/Test/Inter.pm
61 %{_mandir}/man3/Test::Inter.3pm*
62 %{_examplesdir}/%{name}-%{version}
This page took 0.061572 seconds and 2 git commands to generate.