]> git.pld-linux.org Git - SPECS.git/blob - perl-Term-VT102.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / perl-Term-VT102.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Term
6 %define         pnam    VT102
7 Summary:        Term::VT102 - a class to emulate a DEC VT102 terminal
8 Summary(pl.UTF-8):      Term::VT102 - klasa emulująca terminal DEC VT102
9 Name:           perl-Term-VT102
10 Version:        0.91
11 Release:        1
12 License:        Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  210cfacde8d82005a3f08748e0ca8631
16 URL:            http://search.cpan.org/dist/Term-VT102/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 The VT102 class provides emulation of most of the functions of a DEC
24 VT102 terminal. Once initialised, data passed to a VT102 object is
25 processed and the in-memory "screen" modified accordingly. This
26 "screen" can be interrogated by the external program in a variety of
27 ways.
28
29 This allows your program to interface with full-screen console
30 programs by running them in a subprocess and passing their output to a
31 VT102 class. You can then see what the application has written on the
32 screen by querying the class appropriately.
33
34 %description -l pl.UTF-8
35 Klasa VT102 emuluje większość funkcji terminala DEC VT102. Po
36 zainicjowaniu dane przesyłane przez obiekt VT102 są przetwarzane, a
37 "ekran" umieszczony w pamięci odpowiednio modyfikowany. Ten "ekran"
38 może być badany na różne sposoby przez program zewnętrzny.
39
40 Pozwala to programom współpracować z programami pełnoekranowymi
41 poprzez uruchamianie ich w podprocesie i przesyłanie ich wyjścia do
42 klasy VT102. Dzięki temu można widzieć, co aplikacja napisała na
43 ekranie poprzez odpowiednie odpytywanie klasy.
44
45 %prep
46 %setup -q -n %{pdir}-%{pnam}-%{version}
47
48 %build
49 %{__perl} Makefile.PL \
50         INSTALLDIRS=vendor
51 %{__make}
52
53 %{?with_tests:%{__make} test}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 %{__make} install \
59         DESTDIR=$RPM_BUILD_ROOT
60 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
61 cp -p VT102/examples/*.pl $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc Changes README TODO
69 %{perl_vendorlib}/Term/VT102.pm
70 %{_mandir}/man3/*
71 %{_examplesdir}/%{name}-%{version}
This page took 0.259343 seconds and 3 git commands to generate.