]> git.pld-linux.org Git - SPECS.git/blob - perl-Term-Gnuplot.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / perl-Term-Gnuplot.spec
1 #
2 # Conditional build:
3 %bcond_with     svga    # build with svgalib output support
4 %bcond_without  tests   # do not perform "make test"
5 #
6 %define         pdir    Term
7 %define         pnam    Gnuplot
8 Summary:        Term::Gnuplot - lowlevel graphics using gnuplot drawing routines
9 Summary(pl.UTF-8):      Term::Gnuplot - niskopoziomowa grafika przy użyciu funkcji rysujących gnuplota
10 Name:           perl-Term-Gnuplot
11 Version:        0.90380905
12 Release:        16
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  ceccd4e30deb6291ebecce176e715208
18 Patch0:         %{name}-vga.patch
19 Patch1:         format-security.patch
20 URL:            http://search.cpan.org/dist/Term-Gnuplot/
21 BuildRequires:  gd-devel
22 BuildRequires:  perl-devel >= 1:5.8.0
23 %{?with_svga:BuildRequires:     svgalib-devel}
24 BuildRequires:  rpm-perlprov >= 4.1-13
25 BuildRequires:  xorg-lib-libX11-devel
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 This module is intended for low-resolution or high-resolution graphics
30 using gnuplot low-level functions.
31
32 %description -l pl.UTF-8
33 Ten moduł jest przeznaczony do tworzenia grafiki niskiej lub wysokiej
34 rozdzielczości przy użyciu niskopoziomowych funkcji gnuplota.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38 %patch0 -p1
39 %patch1 -p1
40
41 %build
42 %{__perl} Makefile.PL \
43         TRY_LIBS="-lX11 -lm -lgd -lpng -lz %{?with_svga:-lvga}" \
44         INSTALLDIRS=vendor
45 %{__make} \
46         CC="%{__cc}" \
47         OPTIMIZE="%{rpmcflags}"
48
49 %{?with_tests:%{__make} test </dev/null}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc README
63 %{perl_vendorarch}/Term/Gnuplot.pm
64 %dir %{perl_vendorarch}/auto/Term/Gnuplot
65 %attr(755,root,root) %{perl_vendorarch}/auto/Term/Gnuplot/Gnuplot.so
66 %{_mandir}/man3/Term::Gnuplot*
This page took 0.21986 seconds and 3 git commands to generate.