]> git.pld-linux.org Git - packages/perl-Term-Animation.git/blob - perl-Term-Animation.spec
new spec
[packages/perl-Term-Animation.git] / perl-Term-Animation.spec
1
2 # Conditional build:
3 %bcond_without  tests   # do perform "make test"
4
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Term
7 %define pnam    Animation
8 Summary:        Term::Animation - ASCII sprite animation framework
9 Name:           perl-Term-Animation
10 Version:        1.0
11 Release:        1
12 # same as perl
13 License:        GPL/Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  b57a309b6a42051532e809dca6922af1
17 BuildRequires:  perl-devel >= 5.6
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 This module provides a framework to produce sprite animations using ASCII art. 
23 Each ASCII 'sprite' is given one or more frames, and placed into the animation
24 as an 'animation object'. An animation object can have a callback routine that
25 controls the position and frame of the object.
26
27 %prep
28 %setup -q -n %{pdir}-%{pnam}-%{version}
29
30 %build
31 %{__perl} Makefile.PL \
32         INSTALLDIRS=vendor
33
34 %{__make}
35
36 %{?with_tests:make test}
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40 make install DESTDIR=$RPM_BUILD_ROOT
41
42 %clean
43 rm -rf $RPM_BUILD_ROOT
44
45 %files
46 %defattr(644,root,root,755)
47 %{perl_vendorlib}/Term/Animation.pm
48 %{_mandir}/man3/*
This page took 0.05385 seconds and 4 git commands to generate.