]> git.pld-linux.org Git - packages/perl-Template-Toolkit.git/blob - perl-Template-Toolkit.spec
- added defattr to examples and _without_autodeps bcond
[packages/perl-Template-Toolkit.git] / perl-Template-Toolkit.spec
1 #
2 # Conditional build:
3 # _without_autodeps     - don't BR packages needed only for resolving deps
4 # _with_tests           - perform "make test"
5 #
6 %include        /usr/lib/rpm/macros.perl
7 %define pdir    Template
8 %define pnam    Toolkit
9 Summary:        Fast, powerful and easily extensible template processing system
10 Summary(pl):    Rozbudowany i wydajny system szablonów
11 Name:           perl-Template-Toolkit
12 Version:        2.09
13 Release:        1
14 License:        GPL
15 Group:          Development/Languages/Perl
16 #Source0:       http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 Source0:        http://www.template-toolkit.com/download/%{pdir}-%{pnam}-%{version}.tar.gz
18 # Source0-md5:  a69cc8947d2162ec898708fd3ff44b51
19 Patch0:         %{name}-paths.patch
20 Patch1:         %{name}-image.patch
21 URL:            http://www.template-toolkit.org
22 BuildRequires:  perl-devel >= 5.6.1
23 BuildRequires:  perl(File::Spec) >= 0.6
24 BuildRequires:  perl-AppConfig >= 1.52
25 %if 0%{!?_without_autodeps:1}%{?_with_tests:1}
26 BuildRequires:  perl-DBI >= 1.14
27 BuildRequires:  perl-GD >= 1.32
28 BuildRequires:  perl-GD-Graph >= 1.33
29 BuildRequires:  perl-GD-Graph3d >= 0.55
30 BuildRequires:  perl-GD-TextUtil >= 0.80
31 BuildRequires:  perl-Pod-POM >= 0.1
32 BuildRequires:  perl-Text-Autoformat >= 1.03
33 BuildRequires:  perl-XML-Parser >= 2.23
34 BuildRequires:  perl-XML-RSS >= 0.9
35 BuildRequires:  perl-XML-Simple
36 BuildRequires:  perl-XML-XPath >= 1.00
37 BuildRequires:  perl-libxml-enno
38 BuildRequires:  perl(XML::DOM) >= 1.27
39 %endif
40 BuildRequires:  rpm-perlprov >= 4.1-13
41 Requires:       tetex-dvips
42 Requires:       tetex-latex
43 Requires:       tetex-pdftex
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 The Template Toolkit is a collection of modules which implement a
48 fast, flexible, powerful and extensible template processing system. It
49 was originally designed and remains primarily useful for generating
50 dynamic web content, but it can be used equally well for processing
51 any other kind of text based documents: HTML, XML, POD, PostScript,
52 LaTeX, and so on.
53
54 It can be used as a stand-alone Perl module or embedded within an
55 Apache/mod_perl server for generating highly configurable dynamic web
56 content. A number of Perl scripts are also provided which can greatly
57 simplify the process of creating and managing static web content and
58 other offline document systems.
59
60 %description -l pl
61 Template Toolkit to zestaw modu³ów z implementacj± szybkiego,
62 elastycznego, potê¿nego i rozszerzalnego systemu przetwarzania
63 wzorców. Oryginalnie zosta³ zaprojektowany i nadal jest u¿ywany
64 g³ównie do generowania dynamicznych stron WWW, ale mo¿e byæ tak¿e
65 u¿yty do przetwarzania dowolnych innych rodzajów dokumentów
66 tekstowych: HTML, XML, POD, PostScript, LaTeX itd.
67
68 Mo¿e byæ u¿ywany jako samodzielny modu³ Perla, lub wbudowany w serwer
69 Apache/mod_perl do wysoko konfigurowalnego generowania dynamicznych
70 stron WWW. Za³±czonych jest wiele skryptów Perla, które mog± upro¶ciæ
71 proces tworzenia i zarz±dzania statycznymi stronami WWW oraz innymi
72 systemami dokumentów offline.
73
74 %package examples
75 Summary:        Examples for Template Toolkit
76 Summary(pl):    Przyk³ady zastosowania Template Toolkit
77 Group:          Development/Languages/Perl
78
79 %description examples
80 Examples for Template Toolkit
81
82 %description examples -l pl
83 Przyk³ady zastosowania Template Toolkit
84
85 %prep
86 %setup -q -n %{pdir}-%{pnam}-%{version}
87 %patch0 -p1
88 %patch1 -p1
89
90 %build
91 %{__perl} Makefile.PL \
92         INSTALLDIRS=vendor  \
93         TT_DBI=n \
94         TT_LATEX=y \
95         TT_PREFIX=%{_examplesdir}/%{name}-%{version} \
96         TT_IMAGES=%{_examplesdir}/%{name}-%{version}/images \
97         TT_ACCEPT=y
98
99 %{__make} OPTIMIZE="%{rpmcflags}"
100
101 %{?_with_tests:%{__make} test}
102 # GD tests fail as in perl-GD (2.01)
103 # possible explanation - see perl-GD.spec
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107
108 %{__make} install DESTDIR=$RPM_BUILD_ROOT
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %files
114 %defattr(644,root,root,755)
115 %doc Changes HACKING README TODO
116 %attr(755,root,root) %{_bindir}/*
117 %{perl_vendorarch}/Template.pm
118 %{perl_vendorarch}/Template
119 %dir %{perl_vendorarch}/auto/Template
120 %dir %{perl_vendorarch}/auto/Template/Stash
121 %dir %{perl_vendorarch}/auto/Template/Stash/XS
122 %{perl_vendorarch}/auto/Template/Stash/XS/*.bs
123 %attr(755,root,root) %{perl_vendorarch}/auto/Template/Stash/XS/*.so
124 %{_mandir}/man[13]/*
125
126 %files examples 
127 %defattr(644,root,root,755)
128 %{_examplesdir}/%{name}-%{version}
This page took 0.06494 seconds and 3 git commands to generate.