]> git.pld-linux.org Git - packages/perl-TFTP.git/blob - perl-TFTP.spec
new spec
[packages/perl-TFTP.git] / perl-TFTP.spec
1
2 # Conditional build:
3 %bcond_without  tests   # do perform "make test"
4
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    TFTP
7 Summary:        TFTP - Pure perl TFTP implementation
8 Name:           perl-TFTP
9 Version:        1.0b3
10 Release:        1
11 # same as perl
12 License:        GPL/Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{version}.tar.gz
15 # Source0-md5:  0c62ec431f745ca177ab01df3292c803
16 BuildRequires:  perl-devel >= 5.6
17 BuildRequires:  rpm-perlprov >= 4.1-13
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 This is a perl module (completely implemented in perl) to
22 provide the client functionality of the TFTP protocol as described in
23 rfc783. A class, TFTP, is available which encapsulates the persistent
24 aspects of a TFTP connection and from which the basic TFTP operations
25 (get,put) can be initiated.
26
27
28 %prep
29 %setup -q -n %{pdir}-%{version}
30
31 %build
32 %{__perl} Makefile.PL \
33         INSTALLDIRS=vendor
34
35 %{__make}
36
37 %{?with_tests:make test}
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41 make install DESTDIR=$RPM_BUILD_ROOT
42
43 %clean
44 rm -rf $RPM_BUILD_ROOT
45
46 %files
47 %defattr(644,root,root,755)
48 %{perl_vendorlib}/TFTP.pm
49 %{_mandir}/man3/*
This page took 0.026281 seconds and 4 git commands to generate.