]> git.pld-linux.org Git - packages/perl-TFTP.git/blob - perl-TFTP.spec
- converted to UTF-8
[packages/perl-TFTP.git] / perl-TFTP.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    TFTP
7 Summary:        TFTP - pure Perl TFTP implementation
8 Summary(pl.UTF-8):   TFTP - czysto perlowa implementacja TFTP
9 Name:           perl-TFTP
10 Version:        1.0b3
11 Release:        2
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{version}.tar.gz
16 # Source0-md5:  0c62ec431f745ca177ab01df3292c803
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 This is a Perl module (completely implemented in Perl) to provide the
24 client functionality of the TFTP protocol as described in RFC 783. A
25 class, TFTP, is available which encapsulates the persistent aspects of
26 a TFTP connection and from which the basic TFTP operations (get, put)
27 can be initiated.
28
29 %description -l pl.UTF-8
30 To jest moduł Perla (zaimplementowany całkowicie w Perlu)
31 dostarczający funkcjonalność klienta protokołu TFTP opisanego w RFC
32 783. Zawiera klasę TFTP opakowującą stałe aspekty połączenia TFTP,
33 która może zapoczątkowywać podstawowe operacje TFTP (get, put).
34
35 %prep
36 %setup -q -n %{pdir}-%{version}
37
38 %build
39 %{__perl} Makefile.PL \
40         INSTALLDIRS=vendor
41 %{__make}
42
43 %{?with_tests:%{__make} test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc README
57 %{perl_vendorlib}/TFTP.pm
58 %{_mandir}/man3/*
This page took 0.036246 seconds and 4 git commands to generate.