]> git.pld-linux.org Git - packages/perl-TAP-Formatter-HTML.git/blob - perl-TAP-Formatter-HTML.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-TAP-Formatter-HTML.git] / perl-TAP-Formatter-HTML.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    TAP
6 %define         pnam    Formatter-HTML
7 Summary:        TAP::Formatter::HTML - TAP Test Harness output delegate for HTML output
8 Summary(pl.UTF-8):      TAP::Formatter::HTML - moduł TAP Test Harness tworzący wyjście HTML
9 Name:           perl-TAP-Formatter-HTML
10 Version:        0.09
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/TAP/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  897821d527c67c52dfd6df89b70ceec6
17 URL:            http://search.cpan.org/dist/TAP-Formatter-HTML/
18 BuildRequires:  perl-Module-Build >= 0.20
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-File-Temp >= 0.17
23 BuildRequires:  perl-Template-Toolkit >= 2.14
24 BuildRequires:  perl-Template-Toolkit-Plugin-Date >= 2.14
25 BuildRequires:  perl-Test-Harness >= 3.17
26 BuildRequires:  perl-Test-Simple >= 0.01
27 BuildRequires:  perl-URI >= 1.35
28 BuildRequires:  perl-accessors >= 0.02
29 %endif
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 This module provides HTML output formatting for TAP::Harness (a
35 replacement for Test::Harness. It is largely based on ideas from
36 TAP::Test::HTMLMatrix (which was built on Test::Harness and thus had a
37 few limitations - hence this module).
38
39 %description -l pl.UTF-8
40 Ten moduł zapewnia formatowanie wyjścia HTML dla TAP::Harness
41 (zamiennika Test::Harness). Jest w dużej części oparty na ideach
42 TAP::Test::HTMLMatrix (który został stworzony w oparciu o
43 Test::Harness, przez co miał kilka ograniczeń - dlatego powstał ten
44 moduł).
45
46 %prep
47 %setup -q -n %{pdir}-%{pnam}-%{version}
48
49 %build
50 %{__perl} Build.PL \
51         destdir=$RPM_BUILD_ROOT \
52         installdirs=vendor
53 ./Build
54
55 %{?with_tests:./Build test}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 ./Build install
61
62 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
63 cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc Changes Todo
71 # NOTE: move dir to perl-dirs if another plugin appears
72 %dir %{perl_vendorlib}/App/Prove/Plugin
73 %{perl_vendorlib}/App/Prove/Plugin/HTML.pm
74 %{perl_vendorlib}/TAP/Formatter/HTML.pm
75 %{perl_vendorlib}/TAP/Formatter/HTML
76 %{_mandir}/man3/App::Prove::Plugin::HTML.3pm*
77 %{_mandir}/man3/TAP::Formatter::HTML*.3pm*
78 %{_examplesdir}/%{name}-%{version}
This page took 0.036282 seconds and 3 git commands to generate.