]> git.pld-linux.org Git - packages/perl-Sys-Virt.git/blob - perl-Sys-Virt.spec
- adapter
[packages/perl-Sys-Virt.git] / perl-Sys-Virt.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Sys
6 %define         pnam    Virt
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Sys::Virt - Represent and manage a libvirt hypervisor connection
9 #Summary(pl.UTF-8):
10 Name:           perl-Sys-Virt
11 Version:        0.2.6
12 Release:        1
13 License:        GPL
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Sys/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  a4ca5735791e132320bd8546c5deacae
17 URL:            http://search.cpan.org/dist/Sys-Virt/
18 BuildRequires:  libvirt-devel
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl(Test::Pod)
23 BuildRequires:  perl(Test::Pod::Coverage)
24 BuildRequires:  perl(XML::XPath)
25 BuildRequires:  perl(XML::XPath::XMLParser)
26 %endif
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 The Sys::Virt module provides a Perl XS binding to the libvirt virtual
31 machine management APIs. This allows machines running within arbitrary
32 virtualization containers to be managed with a consistent API.
33
34 # %description -l pl.UTF-8 # TODO
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make} -j1 \
43         CC="%{__cc}" \
44         OPTIMIZE="%{rpmcflags}"
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} pure_install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
55 cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc AUTHORS CHANGES INSTALL README
63 %dir %{perl_vendorarch}/Sys
64 %dir %{perl_vendorarch}/Sys/Virt
65 %{perl_vendorarch}/Sys/*.pm
66 %{perl_vendorarch}/Sys/Virt/*.pm
67 %dir %{perl_vendorarch}/auto/Sys/Virt
68 %{perl_vendorarch}/auto/Sys/Virt/*.bs
69 %attr(755,root,root) %{perl_vendorarch}/auto/Sys/Virt/*.so
70 %{_mandir}/man3/*
71 %{_examplesdir}/%{name}-%{version}
This page took 0.105811 seconds and 4 git commands to generate.