]> git.pld-linux.org Git - packages/perl-Sys-Virt.git/blob - perl-Sys-Virt.spec
878f1c8b865a2aceaf74a5dd4688fc4cf114e3e9
[packages/perl-Sys-Virt.git] / perl-Sys-Virt.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # perform "make test" (requires libvirtd)
4 #
5 %define         pdir    Sys
6 %define         pnam    Virt
7 Summary:        Sys::Virt - Represent and manage a libvirt hypervisor connection
8 Summary(pl.UTF-8):      Sys::Virt - reprezentacja i zarządzanie połączeniem z hipernadzorcą libvirt
9 Name:           perl-Sys-Virt
10 Version:        2.5.0
11 Release:        6
12 License:        GPL v2+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Sys/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  d07fca31367bef924ffe5c62e0d5f18a
16 Patch0:         no-dot-in-inc.patch
17 URL:            http://search.cpan.org/dist/Sys-Virt/
18 BuildRequires:  libvirt-devel >= 1.2.19
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  pkgconfig
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 %if %{with tests}
23 BuildRequires:  libvirt-daemon >= 1.2.19
24 BuildRequires:  perl-CPAN-Changes
25 BuildRequires:  perl-Test-Pod
26 BuildRequires:  perl-Test-Pod-Coverage
27 BuildRequires:  perl-Test-Simple
28 BuildRequires:  perl-Time-HiRes
29 BuildRequires:  perl-XML-XPath
30 %endif
31 Requires:       libvirt >= 1.2.19
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 The Sys::Virt module provides a Perl XS binding to the libvirt virtual
36 machine management APIs. This allows machines running within arbitrary
37 virtualization containers to be managed with a consistent API.
38
39 %description -l pl.UTF-8
40 Moduł Sys::Virt dostarcza wiązanie XS Perla do API zarządzania
41 maszynami wirtualnymi libvirt. Pozwala na zarządzanie poprzez
42 jednolite API maszynami wirtualnymi działającymi w dowolnych
43 kontenerach.
44
45 %prep
46 %setup -q -n %{pdir}-%{pnam}-%{version}
47 %patch0 -p1
48
49 %build
50 %{__perl} Makefile.PL \
51         INSTALLDIRS=vendor
52 %{__make} -j1 \
53         CC="%{__cc}" \
54         OPTIMIZE="%{rpmcflags}"
55
56 %{?with_tests:%{__make} test}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 %{__make} pure_install \
62         DESTDIR=$RPM_BUILD_ROOT
63
64 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
65 cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files
71 %defattr(644,root,root,755)
72 %doc AUTHORS Changes README
73 %{perl_vendorarch}/Sys/Virt.pm
74 %dir %{perl_vendorarch}/Sys/Virt
75 %{perl_vendorarch}/Sys/Virt/*.pm
76 %dir %{perl_vendorarch}/auto/Sys/Virt
77 %attr(755,root,root) %{perl_vendorarch}/auto/Sys/Virt/Virt.so
78 %{_mandir}/man3/Sys::Virt*.3pm*
79 %{_examplesdir}/%{name}-%{version}
This page took 0.063174 seconds and 3 git commands to generate.