]> git.pld-linux.org Git - packages/perl-Syntax-Highlight-Engine-Kate.git/blob - perl-Syntax-Highlight-Engine-Kate.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Syntax-Highlight-Engine-Kate.git] / perl-Syntax-Highlight-Engine-Kate.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Syntax
6 %define         pnam    Highlight-Engine-Kate
7 Summary:        Syntax::Highlight::Engine::Kate - a port to Perl of the syntax highlight engine of the Kate texteditor
8 Summary(pl.UTF-8):      Syntax::Highlight::Engine::Kate - perlowy port silnika podświetlania składni z edytora Kate
9 Name:           perl-Syntax-Highlight-Engine-Kate
10 Version:        0.14
11 Release:        1
12 # same as perl 5.8.3+
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Syntax/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  10df4c2d1df9a99f04ec7b03f807e8c2
17 URL:            http://search.cpan.org/dist/Syntax-Highlight-Engine-Kate/
18 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.59
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Term-ANSIColor
23 BuildRequires:  perl-Test-Differences >= 0.61
24 BuildRequires:  perl-Test-Simple >= 1.00
25 BuildRequires:  perl-Test-Warn >= 0.30
26 %endif
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Syntax::Highlight::Engine::Kate is a port to Perl of the syntax
32 highlight engine of the Kate text editor.
33
34 The language XML files of Kate have been rewritten to Perl modules
35 using a script. These modules function as plugins to this module.
36
37 %description -l pl.UTF-8
38 Syntax::Highlight::Engine::Kate to perlowy port silnika podświetlania
39 składni edytora Kate.
40
41 Pliki języków edytora Kate w formacie XML zostały przepisane do
42 modułów Perla przy użyciu skryptu. Funkcjonują jako wtyczki dla tego
43 modułu.
44
45 %prep
46 %setup -q -n %{pdir}-%{pnam}-%{version}
47
48 %build
49 %{__perl} Makefile.PL \
50         INSTALLDIRS=vendor
51 %{__make} \
52         CC="%{__cc}" \
53         OPTIMIZE="%{rpmcflags}"
54
55 %{?with_tests:%{__make} test}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %{__make} pure_install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
64 cp -a eg $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
65 cp -a samples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files
71 %defattr(644,root,root,755)
72 %doc Changes README
73 %dir %{perl_vendorlib}/Syntax
74 %dir %{perl_vendorlib}/Syntax/Highlight
75 %dir %{perl_vendorlib}/Syntax/Highlight/Engine
76 %{perl_vendorlib}/Syntax/Highlight/Engine/Kate.pm
77 %{perl_vendorlib}/Syntax/Highlight/Engine/Kate
78 %{_mandir}/man3/Syntax::Highlight::Engine::Kate*.3pm*
79 %{_examplesdir}/%{name}-%{version}
This page took 0.07496 seconds and 3 git commands to generate.