]> git.pld-linux.org Git - SPECS.git/blob - perl-String-Substrings.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / perl-String-Substrings.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    String
6 %define         pnam    Substrings
7 Summary:        String::Substrings - module to extract some/all substrings from a string
8 Summary(pl.UTF-8):      String::Substrings - moduł do wyciągania części/wszystkich podciągów z ciągu
9 Name:           perl-String-Substrings
10 Version:        0.02
11 Release:        5
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  f733d88cd3f8349946832fb640984842
17 URL:            http://search.cpan.org/dist/String-Substrings/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-String-Random
22 BuildRequires:  perl-Test-Differences
23 BuildRequires:  perl-Test-Exception
24 BuildRequires:  perl-Test-ManyParams
25 BuildRequires:  perl-Test-Simple
26 %endif
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 This module has only one method substrings. It is called as substrings
32 STRING [,LENGTH]. Without a length specification, it returns all
33 substrings with a length of 1 or greater including the string itselfs.
34 The substrings returned are sorted for the length (starting with
35 length 1) and for their index. E.g. substrings "abc" returns
36 ("a","b","c","ab","bc","abc"). This order is guaranteed to stay even
37 in future versions. That also includes that the returned list of
38 substrings needn't be unique. E.g. substrings "aaa" returns
39 ("a","a","a","aa","aa","aaa").
40
41 %description -l pl.UTF-8
42 Ten moduł ma tylko jedną metodę - substrings. Wywołuje się ją jako
43 substrings CIĄG [,DŁUGOŚĆ]. Bez podanej długości, zwraca wszystkie
44 podciągi o długości 1 lub większej, włącznie z całym ciągiem. Zwracane
45 podciągi są posortowane po długości (począwszy od 1) i po indeksie.
46 Np. substrings "abc" zwraca ("a","b","c","ab","bc","abc").
47 Gwarantowane jest zachowanie kolejności w przyszłych wersjach.
48 Zwracana lista podciągów nie musi być unikalna. Np. substrings "aaa"
49 zwraca ("a","a","a","aa","aa","aaa").
50
51 %prep
52 %setup -q -n %{pdir}-%{pnam}-%{version}
53
54 %build
55 %{__perl} Makefile.PL \
56         INSTALLDIRS=vendor
57 %{__make}
58
59 %{?with_tests:%{__make} test}
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63
64 %{__make} install \
65         DESTDIR=$RPM_BUILD_ROOT
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files
71 %defattr(644,root,root,755)
72 %{perl_vendorlib}/%{pdir}/*.pm
73 %{_mandir}/man3/*
This page took 0.265587 seconds and 3 git commands to generate.