]> git.pld-linux.org Git - SPECS.git/blob - perl-Statistics-MaxEntropy.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / perl-Statistics-MaxEntropy.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Statistics
6 %define         pnam    MaxEntropy
7 Summary:        MaxEntropy - Perl5 module for Maximum Entropy Modeling and Feature Induction
8 Summary(pl.UTF-8):      MaxEntropy - moduł do modelowania największej entropii i indukcji cech
9 Name:           perl-Statistics-MaxEntropy
10 Version:        0.9
11 Release:        15
12 License:        GPL v2+
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  b1f7972596653b423e5d65fc7e29f2ee
16 Patch0:         %{name}-paths.patch
17 URL:            http://search.cpan.org/dist/Statistics-MaxEntropy/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-perldoc
22 %endif
23 Requires:       perl-perldoc
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This module is an implementation of the Generalised and Improved
29 Iterative Scaling (GIS, IIS) algorithms and the Feature Induction (FI)
30 algorithm as defined in (Darroch and Ratcliff 1972) and (Della Pietra
31 et al. 1997). The purpose of the scaling algorithms is to find the
32 maximum entropy distribution given a set of events and (optionally) an
33 initial distribution. Also a set of candidate features may be
34 specified; then the FI algorithm may be applied to find and add the
35 candidate feature(s) that give the largest `gain' in terms of Kullback
36 Leibler divergence when it is added to the current set of features.
37
38 %description -l pl.UTF-8
39 Ten moduł jest implementacją algorytmów uogólnionego i ulepszonego
40 iteracyjnego skalowania (GIS, IIS) oraz algorytmu indukcji cech (FI -
41 Feature Induction), zdefiniowanych przez Darrocha i Ratcliffa w 1972
42 roku oraz Della Pietra i innych w 1997. Celem algorytmów skalujących
43 jest znalezienie maksymalnego rozproszenia entropii zadanej zbiorem
44 zdarzeń i (opcjonalnie) początkowym rozproszeniem. Można podać także
45 zbiór cech-kandydatów; wtedy może być zastosowany algorytm FI do
46 odnalezienia i dodanie cech-kandydatów, które dają największy zysk w
47 sensie odchylenia Kullbacka-Leiblera kiedy są dodane do aktualnego
48 zbioru cech.
49
50 %prep
51 %setup -q -n %{pdir}-%{pnam}-%{version}
52 %patch0 -p0
53
54 # kill insecure /tmp usage and possible conflict with another users' builds
55 install -d tmp
56 %{__perl} -pi -e 's@"/tmp"@"tmp"@' t/0[01]*
57
58 %build
59 %{__perl} Makefile.PL \
60         INSTALLDIRS=vendor
61 %{__make}
62
63 %{?with_tests:%{__make} test}
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67
68 %{__make} install \
69         DESTDIR=$RPM_BUILD_ROOT
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %files
75 %defattr(644,root,root,755)
76 %doc Changes README *txt
77 %attr(755,root,root) %{_bindir}/ME.wrapper.pl
78 %{perl_vendorlib}/Statistics/*.pm
79 # empty autosplit.ix files
80 #%%{perl_vendorlib}/auto/Statistics/Candidates
81 #%%{perl_vendorlib}/auto/Statistics/MaxEntropy
82 #%%{perl_vendorlib}/auto/Statistics/SparseVector
83 %{_mandir}/man[13]/*
This page took 0.538735 seconds and 3 git commands to generate.