]> git.pld-linux.org Git - packages/perl-Socket6.git/blob - perl-Socket6.spec
- release 10 (by relup.sh)
[packages/perl-Socket6.git] / perl-Socket6.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Socket6
7 %define         pnam    Socket6
8 Summary:        Socket6 Perl module - IPv6-related part of the C socket.h defines and structure manipulators
9 Summary(pl.UTF-8):      Moduł Perla Socket6 - definicje i operacje na strukturach socket.h związanych z IPv6
10 Name:           perl-Socket6
11 Version:        0.23
12 Release:        10
13 License:        BSD-like
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Socket6/%{pnam}-%{version}.tar.gz
16 # Source0-md5:  2c02adb13c449d48d232bb704ddbd492
17 Patch0:         pod-syntax.patch
18 URL:            http://search.cpan.org/dist/Socket6/
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 The Socket6 module provides glue routines to the various IPv6
25 functions.
26
27 %description -l pl.UTF-8
28 Moduł Socket6 udostępnia perlowy interfejs do różnych funkcji IPv6.
29
30 %prep
31 %setup -q -n %{pnam}-%{version}
32 %patch0 -p1
33
34 %build
35 %{__perl} Makefile.PL \
36         INSTALLDIRS=vendor
37 %{__make}
38 pod2man --section=3pm Socket6.pm >Socket6.3pm
39
40 %{?with_tests:%{__make} test}
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 install -d $RPM_BUILD_ROOT%{_mandir}/man3
45
46 %{__make} install \
47         DESTDIR=$RPM_BUILD_ROOT
48 install Socket6.3pm $RPM_BUILD_ROOT%{_mandir}/man3
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc ChangeLog README
56 %{perl_vendorarch}/Socket6.pm
57 %dir %{perl_vendorarch}/auto/Socket6
58 %attr(755,root,root) %{perl_vendorarch}/auto/Socket6/Socket6.so
59 %{_mandir}/man3/Socket6.3pm*
This page took 0.068105 seconds and 4 git commands to generate.