]> git.pld-linux.org Git - packages/perl-Socket6.git/blob - perl-Socket6.spec
- cosmetics
[packages/perl-Socket6.git] / perl-Socket6.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Socket6
7 %define         pnam    Socket6
8 Summary:        Socket6 Perl module
9 Summary(cs):    Modul Socket6 pro Perl
10 Summary(da):    Perlmodul Socket6
11 Summary(de):    Socket6 Perl Modul
12 Summary(es):    Módulo de Perl Socket6
13 Summary(fr):    Module Perl Socket6
14 Summary(it):    Modulo di Perl Socket6
15 Summary(ja):    Socket6 Perl ¥â¥¸¥å¡¼¥ë
16 Summary(ko):    Socket6 ÆÞ ¸ðÁÙ
17 Summary(nb):    Perlmodul Socket6
18 Summary(pl):    Modu³ Perla Socket6
19 Summary(pt):    Módulo de Perl Socket6
20 Summary(pt_BR): Módulo Perl Socket6
21 Summary(ru):    íÏÄÕÌØ ÄÌÑ Perl Socket6
22 Summary(sv):    Socket6 Perlmodul
23 Summary(uk):    íÏÄÕÌØ ÄÌÑ Perl Socket6
24 Summary(zh_CN): Socket6 Perl Ä£¿é
25 Name:           perl-Socket6
26 Version:        0.17
27 Release:        1
28 License:        BSD-like
29 Group:          Development/Languages/Perl
30 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pnam}-%{version}.tar.gz
31 # Source0-md5:  2ebf9659bedabfd9a128889730455c56
32 BuildRequires:  rpm-perlprov >= 4.1-13
33 BuildRequires:  perl-devel >= 5.6
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 Socket6 is a module that implements a IPv6 API for Perl programs.
38
39 %description -l pl
40 Socket6 jest modu³em umo¿liwiaj±cym dostêp do us³ug IPv6 z poziomu
41 programów Perla.
42
43 %prep
44 %setup -q -n %{pnam}-%{version}
45
46 %build
47 %{__perl} Makefile.PL \
48         INSTALLDIRS=vendor
49 %{__make}
50 pod2man --section=3pm Socket6.pm >Socket6.3pm
51
52 %{?with_tests:%{__make} test}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56 install -d $RPM_BUILD_ROOT%{_mandir}/man3
57
58 %{__make} install \
59         DESTDIR=$RPM_BUILD_ROOT
60 install Socket6.3pm $RPM_BUILD_ROOT%{_mandir}/man3
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc ChangeLog README
68 %{perl_vendorarch}/%{pdir}.pm
69 %dir %{perl_vendorarch}/auto/%{pdir}
70 %{perl_vendorarch}/auto/%{pdir}/%{pdir}.bs
71 %attr(755,root,root) %{perl_vendorarch}/auto/%{pdir}/%{pdir}.so
72 %{_mandir}/man3/*
This page took 0.103931 seconds and 4 git commands to generate.