]> git.pld-linux.org Git - SPECS.git/blob - perl-SVN-Dumpfilter.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / perl-SVN-Dumpfilter.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define pdir    SVN
6 %define pnam    Dumpfilter
7 Summary:        SVN::Dumpfilter - Perl extension to filter Subversion dumpfiles
8 Name:           perl-SVN-Dumpfilter
9 Version:        0.21
10 Release:        2
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/SVN/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  51636274ce0a66d70a889fb3b1911f89
16 URL:            http://search.cpan.org/dist/SVN-Dumpfilter/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 SVN::Dumpfilter reads a Subversion <http://subversion.tigris.org/>
24 dumpfile.
25
26 The file is parsed and a call-back subfunction is called with a
27 hash-reference for every 'node'. This function can modify, add or
28 delete headers, properties and the content of the node. After
29 processing of the call-back function the node is re-assembled and
30 stored in an output file.
31
32 The parse and re-assemble processes are done by dedicated subfunctions
33 which can be also exported ('internal' tag) for special filters (e.g.
34 merging filter which has to write the output file by its own).
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make}
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 %{__make} pure_install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc Changes README
57 %{perl_vendorlib}/SVN/Dumpfilter.pm
58 %{_mandir}/man3/*
This page took 0.347243 seconds and 3 git commands to generate.