]> git.pld-linux.org Git - packages/perl-Return-Value.git/blob - perl-Return-Value.spec
2016f327d07e1e9c6cf1c367d682185ed8ba7b97
[packages/perl-Return-Value.git] / perl-Return-Value.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    Return
6 %define pnam    Value
7 Summary:        Return::Value - Polymorphic Return Values
8 Summary(pl.UTF-8):      Return::Value - Polimorficzne zwracanie wartości
9 Name:           perl-Return-Value
10 Version:        1.666001
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-authors/id/R/RJ/RJBS/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  03128d525392c88e458aa2cd14eb107a
17 URL:            http://search.cpan.org/dist/Return-Value/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl(Test::More) >= 0.47
22 %endif
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Polymorphic return values are really useful. Often, we just want to
28 know if something worked or not. Other times, we'd like to know what
29 the error text was. Still others, we may want to know what the error
30 code was, and what the error properties were. We don't want to handle
31 objects or data structures for every single return value, but we do
32 want to check error conditions in our code because that's what good
33 programmers do.
34
35 When functions are successful they may return true, or perhaps some
36 useful data. In the quest to provide consistent return values, this
37 gets confusing between complex, informational errors and successful
38 return values.
39
40 This module provides these features with a simple API that should get
41 you what you're looking for in each context a return value is used in.
42
43 %description -l pl.UTF-8
44 Polimorficzne wartości zwracane bywają naprawdę przydatne. Często
45 chcemy tylko wiedzieć, czy coś zadziałało, czy nie. Innym razem
46 chcielibyśmy poznać tekstową postać błędu. W jeszcze innym przypadku
47 możemy chcieć poznać kod błędu i jego właściwości. Nie chcemy
48 obsługiwać obiektów czy struktur danych dla każdej zwracanej wartości,
49 ale chcemy sprawdzić w naszym kodzie wystąpienie błędu, ponieważ tak
50 robią dobrzy programiści.
51
52 W przypadku sukcesu funkcje mogą zwrócić wartość true albo jakieś
53 przydatne dane. Przy poszukiwaniu sposobu dostarczenia spójnych
54 wartości błędów, staje się to coraz bardziej zagmatwane pomiędzy
55 złożonymi, informacyjnymi błędami a poprawnymi zwracanymi wartościami.
56
57 Ten moduł dostarcza te możliwości z prostym API, które powinno
58 zapewnić to, czego szukamy w każdym kontekście wykorzystania zwracanej
59 wartości.
60
61 %prep
62 %setup -q -n %{pdir}-%{pnam}-%{version}
63
64 %build
65 %{__perl} Makefile.PL \
66         INSTALLDIRS=vendor
67 %{__make}
68
69 %{?with_tests:%{__make} test}
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73
74 %{__make} install \
75         DESTDIR=$RPM_BUILD_ROOT
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %files
81 %defattr(644,root,root,755)
82 %doc Changes README
83 %dir %{perl_vendorlib}/Return
84 %{perl_vendorlib}/Return/Value.pm
85 %{_mandir}/man3/*
This page took 0.061785 seconds and 3 git commands to generate.